OpenTTD

Tasklist

FS#676 - All trains report in as lost upon leaving depot

Attached to Project: OpenTTD
Opened by de_zeurkous (de_zeurkous) - Tuesday, 13 March 2007, 15:55 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System UNIX
Severity Low
Priority Normal
Reported Version 0.5.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When using classic routing (haven't tested it with the other algorithms) all trains (guided with the TTDPatch non-stop mechanism) report themselves in as lost upon leaving a depot, even though they can perfectly find their way across the network.
This task depends upon

Closed by  KUDr (KUDr)
Tuesday, 13 March 2007, 21:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  r9146 /trunk/src/train_cmd.cpp (2007-03-13 21:04:22 UTC)
-Fix [NTP][ FS#676 ] (r6800): "Train is lost" message is generated incorrectly. Forgot to set the best bird distance to zero in case we found the destination to indicate success. (de_zeurkous)
Comment by KUDr (KUDr) - Tuesday, 13 March 2007, 17:29 GMT
Your savegame has several vehicles complaining about too few orders or invalid order. Nothing about lost vehicles. Didn't you upload wrong file?
Comment by de_zeurkous (de_zeurkous) - Tuesday, 13 March 2007, 17:47 GMT
This _is_ the right file. Send a train -- any train at all -- to a depot (one between checkpoints, of course) and let it leave once it's stopped there. It invariably triggers it. If it still doesn't, try altering the orders in any way. Personally, I have invalid order checking turned off, but it's perfectly possible that my old-school style of routing upsets the entire checking algorithm.
Comment by de_zeurkous (de_zeurkous) - Tuesday, 13 March 2007, 17:48 GMT
...or try cloning the train -- hadn't thought of that, yet. My apologies.
Comment by KUDr (KUDr) - Tuesday, 13 March 2007, 17:58 GMT
No, still no lost trains. Can you try it with the latest trunk head or nightly and save it right before the train leaves depot with the 'lost' message?
Comment by Remko Bijker (Rubidium) - Tuesday, 13 March 2007, 18:13 GMT
I haven't been able to reproduce it. Can you make (and post it here) a savegame where we have to start a train (tell the train number) in a depot and after starting the train shows this bug?
Comment by de_zeurkous (de_zeurkous) - Tuesday, 13 March 2007, 18:20 GMT
Been able to reproduce it with r9131; watch train #4. To try and make sure you see exactly what I see, I've also included the config file I used for both the stable and the nightly snapshot versions.
Comment by KUDr (KUDr) - Tuesday, 13 March 2007, 21:50 GMT
OK, thanks. Finally reproduced here.

Loading...