OpenTTD

Tasklist

FS#6648 - Passengers leaving their train at the wrong station

Attached to Project: OpenTTD
Opened by Chaos (Chaos03) - Tuesday, 02 January 2018, 18:09 GMT
Last edited by andythenorth (andythenorth) - Sunday, 04 March 2018, 09:46 GMT
Type Bug
Category Vehicles → Cargodist
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Normal
Reported Version 1.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

I have a railway line A=B=C with two running trains. The orders of the trains are A->B->C. When the trains go from C to A, they stop at B (as intended) and unload all passengers (including hundreds that want to go to A). Of course the passengers should stay in the train that goes towards A.
This task depends upon

Closed by  andythenorth (andythenorth)
Sunday, 04 March 2018, 09:46 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Thanks for reporting this.

This is a conflict between cargo distribution and conditional orders. Cargo distribution has a hard time with order jumps and conditional orders as it can't predict the results. Unlikely to be ever fixed, so closing. Thanks :)
Comment by Chaos (Chaos03) - Tuesday, 02 January 2018, 18:10 GMT
Something went wrong with the attachments.

Loading...