OpenTTD

Tasklist

FS#6641 - NewGRF/Online Content Server and no Config file for 1.7.1

Attached to Project: OpenTTD
Opened by You dont really need to know. (Wulf) - Friday, 24 November 2017, 01:31 GMT
Last edited by Alberth (Alberth) - Tuesday, 19 December 2017, 06:39 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Critical
Priority Normal
Reported Version 1.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When clicking on the Check online content button in the main menu all that shows up is blank menu. If you wait for a moment it will vanish with the text "Could not connect to Content server...". Along with this there is no config file for OpenTTD. Note everything works fine just not the NewGRF content so I can't play on any Modded/NewGRF servers.
This task depends upon

Closed by  Alberth (Alberth)
Tuesday, 19 December 2017, 06:39 GMT
Reason for closing:  Not a bug
Additional comments about closing:  not fixable in openttd
Comment by You dont really need to know. (Wulf) - Friday, 24 November 2017, 01:34 GMT
Forgot to add the images to it
Comment by Alberth (Alberth) - Tuesday, 19 December 2017, 06:45 GMT
Comment I wrote got lost, here it is again...

It seems you don't have a path from the local openttd program to the content server. Most likely cause is that the Internet traffic is blocked by a firewall between openttd and your ISP. Check the settings of the firewall at your local machine, and the modem/router to the ISP.

Since all this is outside the scope of the openttd program, there isn't anything we can do to fix it.


Config file gets written when you exit the program, assuming you have sufficient permissions for writing in the target directory.

Loading...