OpenTTD

Tasklist

FS#6617 - Makes the upgrade/convert tool upgrade trains stationed in depots between incompatible rail types

Attached to Project: OpenTTD
Opened by Hal Gentz (zegentzy) - Thursday, 31 August 2017, 08:51 GMT
Last edited by andythenorth (andythenorth) - Saturday, 02 September 2017, 13:11 GMT
Type Feature Request
Category Interface
Status With patch
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 1.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Ever upgraded from rail to monorail (or manglevs)? Annoyed at having to recreate all your trains? I got the solution for you!

This patch allows the upgrading of depots containing parked trains. It also autoreplaces all trains in said depots.

Now you can:
1- Set autoreplace to upgrade rail engines/wagons to monorail (or manglave) engines/wagons.
2- Send all trains to a depot
3- Use the upgrade/convert tool on the depot!
4- Watch as all your trains are now monorail/manglev, no order cloning of 400 trains required!

Changes:
1- Made autoreplace gui show incompatible rail types - as far as I can tell trains don't upgrade to non-compatible rail types of the depot can't buy the rail type so this should have no effect on anything
2- Reworked Upgrade rails command to still upgrade depot tiles if they have trains on em' only if all trains are stationed in the depot. It then calls autoreplace on all those trains.
This task depends upon

Loading...