OpenTTD

Tasklist

FS#661 - restart

Attached to Project: OpenTTD
Opened by norko (norko) - Saturday, 03 March 2007, 20:48 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Critical
Priority Normal
Reported Version 0.5.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I start the game as a server, it writes "could not start new server" (or something) in red table... but when I type "restart" in console, the game crashes...
But when I restart the game not in server mode, it restarts with any problem


*** OpenTTD Crash Report ***
Date: 2007-03-03 13:43:06
Build: 0.5.0 built on Feb 27 2007 18:05:44
Exception C0000005 at 00000000
Registers:
EAX: 004F61DC EBX: 01E10208 ECX: 01E10048 EDX: 00003E6B
ESI: 01E10120 EDI: 01E10048 EBP: 00000000 ESP: 0012FB20
EIP: 00000000 EFLAGS: 00010256

Bytes at CS:EIP:
?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ?? ??

Stack trace:
0046E196 000006B8 0000056F 01E10048 00000002 00000007 0046E338 01E10048
00000007 0000000E 0012FB68 01E10048 004701F1 00000001 01E10048 01E10048
00000000 00005A6C 77D4E655 00470346 01E10048 01E10048 00000000 00470399
00000000 05ED46E9 0042EC70 00000000 05ED46E9 00000000 00422FD8 00000000
00423249 00000000 00438803 005B2E10 005B7B90 0012FC0C 00000001 05ED4707
00000000 00000000 007A07DE 00000113 00000001 0043791B 05ED46E9 000002FA
00000206 004229BD 0012FC94 00000001 7FFDE000 0000FD00 000206D8 00000000
00020744 0012FC2C 7C821692 00000039 FFFFFFFF 00000000 00000104 0000FDE9
0012FC94 7FFDE000 00000036 0012FC58 7C8215EB 0000FD00 00000000 000206D8
FFFFFFFF 0012FC94 00000104 00000000 00000000 00000000 00000000 FFFFFFFF
0000FDE9 FFFFFFFF 0012FD9C 005283F4 00000000 00000000 FFFFFFFF 0000FE98
0012FE98 00436F2A 0012FD98 7C80B6A1 00000000 5C3A6322 6B726F4E 61475C6F
5C73656D 79616C50 65704F5C 6F53206E 65637275 63795420 5C6E6F6F 6E65706F
2E647474 00657865 006F0020 006E006F 006F005C 00650070 0074006E 00640074
0065002E 00650078 EBEA0000 EFEEEDEC F3F2F1F0 D7F6F5F4 FBFAF9F8 DFFEFDFC
E3E2E1E0 E7E6E5E4 EBEAE9E8 EFEEEDEC F3F2F1F0 F7F6F5F4 FBFAF9F8 FFFEFDFC
03020120 07060504 0B0A0908 0F0E0D0C 13121110 17161514 1B1A1918 1F1E1D1C
23222120 27262524 2B2A2928 2F2E2D2C 33323130 37363534 3B3A3938 3F3E3D3C
43424140 47464544 4B4A4948 4F4E4D4C 53525150 57565554 5B5A5958 5F5E5D5C
63626160 67666564 6B6A6968 6F6E6D6C 73727170 77767574 0012FC95 7F7E7D7C
83828180 87868584 8B8A8988 8F8E8D8C 93929190 97969594 9B9A9998 9F9E9D9C
A3A2A1A0 A7A6A5A4 ABAAA9A8 AFAEADAC B3B2B1B0 B7B6B5B4 BBBAB9B8 BFBEBDBC
C3C2C1C0 C7C6C5C4 CBCAC9C8 CFCECDCC D3D2D1D0 D7D6D5D4 DBDAD9D8 DFDEDDDC
E3E2E1E0 E7E6E5E4 0052E024 004C5DCF 0012FE50 004C6DFD 00CC0000 00000000

Module information:
c:NorkoGamesPlayOpen Source Tycoonopenttd.exe handle: 00400000 size: 1292800 crc: 2BA20BBE date: 2007-02-28 01:09:40
C:WINDOWSsystem32ntdll.dll handle: 7C900000 size: 708096 crc: A5A50370 date: 2004-08-04 08:00:00
C:WINDOWSsystem32kernel32.dll handle: 7C800000 size: 984064 crc: FAF3AFF3 date: 2006-07-05 10:55:01
C:WINDOWSsystem32WINMM.dll handle: 76B40000 size: 176128 crc: 123646FA date: 2004-08-04 08:00:00
C:WINDOWSsystem32USER32.dll handle: 77D40000 size: 577024 crc: 68A1AA4A date: 2005-03-02 18:09:30
C:WINDOWSsystem32GDI32.dll handle: 77F10000 size: 280064 crc: BE157002 date: 2005-12-29 02:54:35
C:WINDOWSsystem32ADVAPI32.dll handle: 77DD0000 size: 616960 crc: 5E7A2F0A date: 2004-08-04 08:00:00
C:WINDOWSsystem32RPCRT4.dll handle: 77E70000 size: 581120 crc: 3AE05623 date: 2004-08-04 08:00:00
C:WINDOWSsystem32WS2_32.dll handle: 71AB0000 size: 82944 crc: 9738CC56 date: 2004-08-04 08:00:00
C:WINDOWSsystem32msvcrt.dll handle: 77C10000 size: 343040 crc: 5298C0C5 date: 2004-08-04 08:00:00
C:WINDOWSsystem32WS2HELP.dll handle: 71AA0000 size: 19968 crc: F5DD5AB6 date: 2004-08-04 08:00:00
C:WINDOWSsystem32IMM32.DLL handle: 76390000 size: 110080 crc: FD65A0DD date: 2004-08-04 08:00:00
C:WINDOWSsystem32LPK.DLL handle: 629C0000 size: 22016 crc: 3AC484CC date: 2004-08-04 08:00:00
C:WINDOWSsystem32USP10.dll handle: 74D90000 size: 406528 crc: 826D7E56 date: 2004-08-04 08:00:00
C:Program FilesCommon FilesLogishrdLVMVFMLVPrcInj.dll handle: 00CD0000 size: 92960 crc: 713570FD date: 2006-12-22 19:32:58
C:WINDOWSsystem32WINTRUST.dll handle: 76C30000 size: 176640 crc: 88D208BD date: 2004-08-04 08:00:00
C:WINDOWSsystem32CRYPT32.dll handle: 77A80000 size: 597504 crc: 971ECFAA date: 2004-08-04 08:00:00
C:WINDOWSsystem32MSASN1.dll handle: 77B20000 size: 57344 crc: D5127637 date: 2004-08-04 08:00:00
C:WINDOWSsystem32IMAGEHLP.dll handle: 76C90000 size: 144384 crc: 714A70BC date: 2004-08-04 08:00:00
C:WINDOWSsystem32wdmaud.drv handle: 72D20000 size: 23552 crc: 982E84EE date: 2004-08-04 08:00:00
C:WINDOWSsystem32msacm32.drv handle: 72D10000 size: 20480 crc: D5406BAE date: 2004-08-04 08:00:00
C:WINDOWSsystem32MSACM32.dll handle: 77BE0000 size: 71680 crc: 6A21891E date: 2004-08-04 08:00:00
C:WINDOWSsystem32midimap.dll handle: 77BD0000 size: 18944 crc: 502B5282 date: 2004-08-04 08:00:00
C:WINDOWSsystem32ole32.dll handle: 774E0000 size: 1285120 crc: AD325A7F date: 2005-07-26 04:39:48
C:WINDOWSsystem32uxtheme.dll handle: 5AD70000 size: 218624 crc: 5AA98F22 date: 2004-08-04 08:00:00
C:WINDOWSsystem32MSCTF.dll handle: 74720000 size: 294400 crc: BBD2E653 date: 2004-08-04 08:00:00
C:WINDOWSsystem32CLBCATQ.DLL handle: 76FD0000 size: 498688 crc: 9DED030F date: 2005-07-26 04:39:43
C:WINDOWSsystem32COMRes.dll handle: 77050000 size: 792064 crc: 5A12B4A2 date: 2004-08-04 08:00:00
C:WINDOWSsystem32OLEAUT32.dll handle: 77120000 size: 553472 crc: 78035CFF date: 2004-08-04 08:00:00
C:WINDOWSsystem32VERSION.dll handle: 77C00000 size: 18944 crc: CFE439BB date: 2004-08-04 08:00:00
C:WINDOWSsystem32dmime.dll handle: 5C570000 size: 181248 crc: F18E50F8 date: 2004-08-04 08:00:00
C:WINDOWSsystem32DSOUND.dll handle: 73F10000 size: 367616 crc: F0EFB582 date: 2004-08-04 08:00:00
C:WINDOWSsystem32dmusic.dll handle: 6C980000 size: 104448 crc: 0C1C73CE date: 2004-08-04 08:00:00
C:WINDOWSsystem32KsUser.dll handle: 73EE0000 size: 4096 crc: 519CF22C date: 2004-08-04 07:56:44
C:WINDOWSsystem32dmsynth.dll handle: 6C9A0000 size: 103424 crc: ECEFF055 date: 2004-08-04 08:00:00
C:WINDOWSsystem32dmloader.dll handle: 6CA10000 size: 35840 crc: CCCBFD58 date: 2004-08-04 08:00:00
C:WINDOWSsystem32msctfime.ime handle: 755C0000 size: 177152 crc: 6A712F98 date: 2004-08-04 08:00:00
C:WINDOWSsystem32imon.dll handle: 20B00000 size: 299392 crc: 4EB51141 date: 2007-01-20 23:58:30
C:WINDOWSsystem32WSOCK32.dll handle: 71AD0000 size: 22528 crc: 6E514A7A date: 2004-08-04 08:00:00
C:WINDOWSsystem32mswsock.dll handle: 71A50000 size: 245248 crc: E2309390 date: 2004-08-04 08:00:00
C:WINDOWSsystem32hnetcfg.dll handle: 662B0000 size: 344064 crc: 6CF15ACF date: 2004-08-04 08:00:00
C:WINDOWSSystem32wshtcpip.dll handle: 71A90000 size: 19968 crc: B88CC0E5 date: 2004-08-04 08:00:00
C:Program FilesHPQQuick Launch ButtonsCPQINFO.DLL handle: 10000000 size: 282624 crc: FDE34EC1 date: 2005-11-30 22:31:34
C:WINDOWSsystem32SHELL32.dll handle: 7C9C0000 size: 8453632 crc: 08BB85F6 date: 2006-12-19 21:52:18
C:WINDOWSsystem32SHLWAPI.dll handle: 77F60000 size: 474112 crc: 5DD4E42F date: 2006-10-23 15:17:53
C:WINDOWSWinSxSx86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.2982_x-ww_ac3f9c03comctl32.dll handle: 773D0000 size: 1054208 crc: 58D6578C date: 2006-08-25 15:45:55
C:WINDOWSsystem32comctl32.dll handle: 5D090000 size: 617472 crc: 232F6674 date: 2006-08-25 15:45:58
C:WINDOWSsystem32psapi.dll handle: 76BF0000 size: 23040 crc: 97A44A88 date: 2004-08-04 08:00:00

System information:
Windows version 5.1 2600 S
This task depends upon

Closed by  Darkvater (Darkvater)
Sunday, 04 March 2007, 21:36 GMT
Reason for closing:  Not a bug
Additional comments about closing:  0.0.0.0 simply means that the server is listening on *ANY* ip your pc might have. That could be your internal IP, your VPN ip, the IP of your other network card, etc. So that is not a problem.
You can set a specific IP by setting the appropiate value.
Comment by Darkvater (Darkvater) - Saturday, 03 March 2007, 21:31 GMT
That crash.dmp file is not from 0.5.0-final but from RC1. 0.5.0 does not create a crashdump.
Clearly the game for some reason cannot create a server, please start the binary with:
openttd.exe -d net=10
and see what output you get. I will close your other bugreport as it's simply a duplicate.
Comment by norko (norko) - Saturday, 03 March 2007, 22:32 GMT
ok.... i didn't know about that crash.dmp... there was written to send it, too.
I attached screen of what do i get when i start the game with openttd.exe -d net=10.
first i used all addons and then i turned them off, but nothing changed... :((
the same think occurs "could not start the server"...
Comment by Darkvater (Darkvater) - Saturday, 03 March 2007, 23:18 GMT
Can you try deleting your openttd.cfg and starting a server that way? That 'listening on 0.0.0.0:0' doesn't sound too good.
Comment by norko (norko) - Saturday, 03 March 2007, 23:26 GMT
Ok I deleted that file and it does work, but... see picture
do you have to set up ip address manualy???
Comment by norko (norko) - Saturday, 03 March 2007, 23:30 GMT
after using "openttd.exe -d net=10"... the port it listens to is still 0.0.0.0:something... at least it is not 0.0.0.0:0
Can it be because of my router or something??? that my ip in network connections (in windows) is 192.168.1.101???

Loading...