OpenTTD

Tasklist

FS#6602 - unknown cargo

Attached to Project: OpenTTD
Opened by Peter (eenander) - Friday, 11 August 2017, 16:06 GMT
Last edited by andythenorth (andythenorth) - Monday, 21 August 2017, 09:40 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version Version?
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Unknown cargo is not easy to repair. Please a solution.
This task depends upon

Closed by  andythenorth (andythenorth)
Monday, 21 August 2017, 09:40 GMT
Reason for closing:  Bug in NewGRF
Additional comments about closing:  Thanks for the savegame in #6601 - I can reproduce this issue in that savegame.

Game contains both ECS Vectors and Manual Industries. Two industry grfs don't work in one game, unless they're designed explicitly to be compatible :)

You're not the first person to discover this, and won't be the last either. I've done the same thing, until I knew better.

Some industry grfs include checks for other industry sets, but not all industry grfs do that.
Comment by Alberth (Alberth) - Saturday, 12 August 2017, 11:50 GMT
This is a classic sympton of a savegame where you modified a NewGRF and continued to play.
Please provide a savegame without such modifications to show the problem
Comment by andythenorth (andythenorth) - Monday, 21 August 2017, 07:12 GMT
See also  FS#6601 

Let this and 6601 run out 30 days then close both if no savegame provided. These issues are almost universally caused by player-changed newgrfs, but there's always a chance it's a legitimate bug.

Loading...