OpenTTD

Tasklist

FS#6601 - Carco accept different between factory and station

Attached to Project: OpenTTD
Opened by Peter (eenander) - Friday, 11 August 2017, 16:04 GMT
Last edited by andythenorth (andythenorth) - Monday, 21 August 2017, 09:39 GMT
Type Bug
Category NewGRF → NewCargos
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 1.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Different between the station cargo and the factory cargo accept.
This task depends upon

Closed by  andythenorth (andythenorth)
Monday, 21 August 2017, 09:39 GMT
Reason for closing:  Bug in NewGRF
Additional comments about closing:  Thanks for the savegame.

Game contains both ECS Vectors and Manual Industries. Two industry grfs don't work in one game, unless they're designed explicitly to be compatible :)

You're not the first person to discover this, and won't be the last either. I've done the same thing, until I knew better.

Some industry grfs include checks for other industry sets, but not all industry grfs do that.
Comment by Peter (eenander) - Friday, 11 August 2017, 16:15 GMT
Pictures
Comment by Daniele (Wolf01) - Saturday, 12 August 2017, 11:14 GMT
Hello, could you provide more informations about this problem and  FS#6602  too (which I think it might be related)?

Especially we need to know:
1. List of grfs used
2. Bigger pictures of the station showing its surroundings
3. Did you ever tried to change grfs while playing, or updated grfs and removed the old ones so the game loaded the new ones in compatibility mode?
Comment by adf88 (adf88) - Saturday, 19 August 2017, 11:32 GMT
Or just upload a savegame file if you can.
Comment by andythenorth (andythenorth) - Monday, 21 August 2017, 07:12 GMT
Let this and related  FS#6602  run out 30 days then close both if no savegame provided. These issues are almost universally caused by player-changed newgrfs, but there's always a chance it's a legitimate bug.
Comment by Peter (eenander) - Monday, 21 August 2017, 09:21 GMT
here the saved game. Factory 2 has a difference.

Loading...