OpenTTD

Tasklist

FS#6535 - Too many available vehicles causes names to disappear.

Attached to Project: OpenTTD
Opened by Hector Charlie Readman (DenLillePrins) - Friday, 30 December 2016, 01:05 GMT
Last edited by frosch (frosch) - Saturday, 11 March 2017, 23:05 GMT
Type Bug
Category Interface
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 1.6.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If one has to many .grfs then the names of vehicles do not load for .grfs that are at the bottom ofthe list, you can see this in screen shot 1, in screen shot 2 you can see that it is likely caused by a limited number or places for a name to go within the game files??? The bug is not .grf specific and can be recreated with other .grfs, it does not impact how the vehicle works only its display name and the name under the information tab as also shown. The bug does not cause the game to crash and can be easily replicated (which is why I have not attached the .sav file or other .grfs)

Windows 10 Home
   bug1.png (433.2 KiB)
   bug2.png (340.7 KiB)
This task depends upon

Closed by  frosch (frosch)
Saturday, 11 March 2017, 23:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r27758
Comment by frosch (frosch) - Wednesday, 04 January 2017, 11:45 GMT

Loading...