OpenTTD

Tasklist

FS#6473 - It stops and doesn't save

Attached to Project: OpenTTD
Opened by Adrià (adriaesc) - Sunday, 29 May 2016, 11:48 GMT
Last edited by frosch (frosch) - Monday, 30 May 2016, 21:03 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Medium
Priority Normal
Reported Version 1.6.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I arrive to 31st of December of 1980, it "locks" itself, the CPU goes higher and I cannot continue playing so I must stop it. I haven't passed that year because it cannot save.
I am using the 1.6.0 version in Windows 10.
This task depends upon

Closed by  frosch (frosch)
Monday, 30 May 2016, 21:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r27594
Comment by Adrià (adriaesc) - Sunday, 29 May 2016, 11:51 GMT
The crash log, png and sav are from an older game and I cannot take a recent one. Sorry.
Comment by Alberth (Alberth) - Sunday, 29 May 2016, 17:22 GMT
Please do not add files that are not related to the problem, it confuses the issue.

Which files are now actually part of this problem?
Only autosave0.sav ? Please let us know which files can be deleted from this issue.

As for autosave0.sav, I cannot run it, as I am missing the "spainsetw" newgrf: NewGRF 45530101 (spainsetw.grf) not found; checksum 98FBBAEBB652B296DF7958ED0ADF7C8D"
It is not at bananas. If the license permits it, can you add it here, or else tell us where it can be found?

I see you changed the category to gamescript. Does that mean you used a game script?
The game does not store that, can you add the script too?


Basically, we need everything to reproduce the issue. Once it gets stuck like your machine does, we can start looking for the cause.
Comment by Adrià (adriaesc) - Sunday, 29 May 2016, 18:19 GMT
The only file that goes there is autosave0.sav
I downloaded Spanish Set in the game. There, it is called Spanish Set Taster.
I put that category because it was the one that corresponded more with the issue, but maybe is NewGRF.
Comment by Alberth (Alberth) - Monday, 30 May 2016, 14:47 GMT
Deleted the crash files, as they didn't relate to the issue
Comment by frosch (frosch) - Monday, 30 May 2016, 17:41 GMT
Caused by MailAI v21. The AI seems to use nested valuators which results at least in O(n^2) complexity.

To continue your game, open the in-game console (using the key left to 1, which may be ^ ~ ` or some other fancy character), and type:
stop_ai 2
That will kill company 2 (Mail AI) and you can continue playing.
Comment by Adrià (adriaesc) - Monday, 30 May 2016, 20:33 GMT
Thanks! Now works!

Loading...