OpenTTD

Tasklist

FS#6441 - Can't see aircraft and ship income in finances.

Attached to Project: OpenTTD
Opened by Artur (aarturr) - Wednesday, 06 April 2016, 22:07 GMT
Last edited by andythenorth (andythenorth) - Friday, 25 August 2017, 09:59 GMT
Type Bug
Category Interface
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 1.6.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Can't see aircraft and ship income in finances (i use russian language if it matters).
This task depends upon

Closed by  andythenorth (andythenorth)
Friday, 25 August 2017, 09:59 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Not a bug - explanation provided in comments :)

Flyspray clean up - closing this. Thanks for reporting it, appreciated.
Comment by Alberth (Alberth) - Saturday, 16 April 2016, 15:15 GMT
So many windows and numbers at those screens, can't you make a simpler example?
I don't know where to look.

Fwiw, I am guessing your aircraft and ships don't deliver to final destinations, instead they deliver to intermediate stations where other transport picks the cargo up.
If so, the behavior is correct. Money obtained by intermediate transport (yellow money) ends up for the vehicle that delivers it to its final destination, afaik.
Comment by 3298 (3298) - Friday, 25 August 2017, 09:54 GMT
The above comment was just a guess, but luckily we have a save to check. It contains no planes, and all ships' orders are transfer and leave empty at <x>, full load any at <y>. Thus Alberth's suspicion was correct, there is no non-virtual profit from planes or ships.

Loading...