OpenTTD

Tasklist

FS#644 - RC5 game speed

Attached to Project: OpenTTD
Opened by Merlin the Magician (Merlin the Magician) - Friday, 23 February 2007, 07:47 GMT
Last edited by Remko Bijker (Rubidium) - Friday, 09 March 2007, 14:21 GMT
Type Bug
Category Script → Original
Status Closed
Assigned To Celestar (Celestar)
Operating System All
Severity High
Priority High
Reported Version trunk
Due in Version 0.5.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

OpenTTD 0.5.0 RC5 seems to have some trouble that needs attention.
Started a new game, standard landscape (green) map size 2048x2048, normal number of towns, high number of industries, hilly terrain, sea level very low, flats smooth. Picked a yellew colour scheme and random directors face (for what that’s worth)

At first, everything seems to work just fine, but from date October 1951, the game runs into some trouble. Speed of the game drastically decreases and does not recover. Vehicles move in shocks from one screen position to another, scrolling goes in shocks as well.
Basically, the game becomes unplayable. I left the controls in peace for a few minutes, but the game does not switch back to normal game speed.

This event was not random. I restarted my entire pc for a few times and attempted start a new game with equal settings. Problem however remained, so this seems structural.

Irritated as I was… reinstalled OpenTTD 0.4.8 to see what would happen if I created a new game with equal settings there. This worked like a charm….

In conclusion…. I think this needs a little attentiona
This task depends upon

Closed by  Celestar (Celestar)
Friday, 16 March 2007, 10:11 GMT
Reason for closing:  Fixed
Comment by Darkvater (Darkvater) - Friday, 23 February 2007, 11:14 GMT
Try turning off the AI and see what happens then.
Comment by blove (blove) - Sunday, 25 February 2007, 23:00 GMT
It definitely seems to be an issue with the AI. I was able to reproduce pretty easily. And when I used the same save-game but disabled the AI, the problem went away.

On my machine the slow down did seem to come and go (not constant); specifically, it seemed to happen when the AI was calculating new routes. Once the route was in place, the game sped up again -- until the next time the AI decided to build. Also, the longer the slowdown lasted, the more complex was the subsequent route the AI built.
Comment by blove (blove) - Sunday, 25 February 2007, 23:05 GMT
I forgot to mention: I was using trunk, r8903.

Loading...