OpenTTD

Tasklist

FS#6430 - Crash: [OS X] autosave fails and the whole game crashes

Attached to Project: OpenTTD
Opened by Tomi "bgt" Suovuo (bgt) - Friday, 11 March 2016, 15:09 GMT
Last edited by andythenorth (andythenorth) - Wednesday, 30 August 2017, 19:56 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Mac OS X
Severity Low
Priority High
Reported Version 1.5.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Game just crashes with the message "A serious gault condition occurred in the game. The game will shutdown." Window updating goes haywire. No warning before.

The last autosave is saying "Internal error: liblzma returned error code" when restarting OpenTTD and checking through the autosaves. I also include the faulty autosave (autosave8), and the previous, non-faulty autosave (autosave7).

My OS X version is El Capitan 10.11.3.

I wasn't doing anything particular, and this happened for the second time now. I do use quite a set of GRF mods. The preset is the one called bgt201603, which I assume can be found in the openttd.cfg-file.

Below is the list of the NewGRF files I have downloaded, but not all of them is selected for the game. (Conflicts: e.g. FIRS doesn't start with the ECSs.)

-rw-r--r-- 1 bgt staff 593920 Mar 4 20:00 2CC_Trams-0.1.0beta2.tar
-rw-r--r-- 1 bgt staff 399360 Mar 4 20:00 832bpp_Canton_BusesCHN-0.2.tar
-rw-r--r-- 1 bgt staff 30720 Mar 4 20:01 Airport_asphalt_ttdur-1.0.tar
-rw-r--r-- 1 bgt staff 133120 Mar 4 20:00 Alexandra_Palace-1.0.0.tar
-rw-r--r-- 1 bgt staff 2836480 Mar 4 20:01 Austailian_Industry_V3-5.tar
-rw-r--r-- 1 bgt staff 204800 Mar 4 20:01 Av9.8-0.83.tar
-rw-r--r-- 1 bgt staff 163840 Mar 4 20:00 BATS-0.4.tar
-rw-r--r-- 1 bgt staff 133120 Mar 4 20:01 BK_Enhanced_Tunnel_Set-1.0.tar
-rw-r--r-- 1 bgt staff 563200 Mar 4 20:00 Beach_Objects-1.2.tar
-rw-r--r-- 1 bgt staff 143360 Mar 4 20:00 Bobs_British_Buses-0.2.1.tar
-rw-r--r-- 1 bgt staff 30720 Mar 4 20:01 Brianum_BR_611-1.0.tar
-rw-r--r-- 1 bgt staff 40960 Mar 4 20:01 Brianum_BR_628-1.0.tar
-rw-r--r-- 1 bgt staff 30720 Mar 4 20:01 Brianum_BR_641_Alstom_Coradia_-1.0.tar
-rw-r--r-- 1 bgt staff 30720 Mar 4 20:01 Brianum_SH_50__SH_60-1.0.1.tar
-rw-r--r-- 1 bgt staff 30720 Mar 4 20:01 Brianum_Speedlimit_for_monorail-1.0.tar
-rw-r--r-- 1 bgt staff 61440 Mar 4 20:01 Brianum_VacuumMonorail_Tube-1.0.tar
-rw-r--r-- 1 bgt staff 51200 Mar 4 20:01 Brianum_VakuumMonorail_Trains-1.02.tar
-rw-r--r-- 1 bgt staff 30720 Mar 4 20:01 Brianum_X2014__Millennium_Z-1.0.1.tar
-rw-r--r-- 1 bgt staff 30720 Mar 4 20:01 Brianum_speed_limit_for_bridges-1.0.tar
-rw-r--r-- 1 bgt staff 40960 Mar 4 20:00 Brick_Tram_Depot-1.0.0.tar
-rw-r--r-- 1 bgt staff 112640 Mar 4 20:01 CS_Cargo-0.3.tar
-rw-r--r-- 1 bgt staff 61440 Mar 4 20:00 CS_Platforms_set-1.tar
-rw-r--r-- 1 bgt staff 204800 Mar 4 20:00 CS_StationSet_v0.1-1-4.tar
-rw-r--r-- 1 bgt staff 225280 Mar 4 20:00 CS_extras_set-1.tar
-rw-r--r-- 1 bgt staff 563200 Mar 4 20:01 City_Objects-B08.1.tar
-rw-r--r-- 1 bgt staff 81920 Mar 4 20:00 City_Tram_Set-B02.tar
-rw-r--r-- 1 bgt staff 112640 Mar 4 20:01 City_Tram_Track-B06.tar
-rw-r--r-- 1 bgt staff 61440 Mar 4 20:00 City_stations-1.tar
-rw-r--r-- 1 bgt staff 20480 Mar 4 20:00 Cow_farms-1.tar
-rw-r--r-- 1 bgt staff 348160 Mar 4 20:01 DACH_Trains-0.3.2.tar
-rw-r--r-- 1 bgt staff 30720 Mar 4 20:00 Dock_with_containers_and_crane-1.0.tar
-rw-r--r-- 1 bgt staff 1955840 Mar 4 20:00 ECS_Agricultural_Vector-1.219feb2012.tar
-rw-r--r-- 1 bgt staff 624640 Mar 4 20:00 ECS_Basic_vector-B525Nov2009.tar
-rw-r--r-- 1 bgt staff 1095680 Mar 4 20:00 ECS_Basic_vector_II-1.219feb2012.tar
-rw-r--r-- 1 bgt staff 286720 Mar 4 20:00 ECS_Chemical_vector_II-1.219feb2012.tar
-rw-r--r-- 1 bgt staff 174080 Mar 4 20:00 ECS_Construction_Vector-B527Dec2010.tar
-rw-r--r-- 1 bgt staff 583680 Mar 4 20:00 ECS_Houses-1.219feb2012.tar
-rw-r--r-- 1 bgt staff 40960 Mar 4 20:01 ECS_Industry_Addon-2012.12.26.tar
-rw-r--r-- 1 bgt staff 2406400 Mar 4 20:00 ECS_Machinery_vector-1.219feb2012.tar
-rw-r--r-- 1 bgt staff 1003520 Mar 4 20:01 ECS_Town_vector-1.1.219Jun2011.tar
-rw-r--r-- 1 bgt staff 1003520 Mar 4 20:00 ECS_Town_vector-1.219feb2012.tar
-rw-r--r-- 1 bgt staff 522240 Mar 4 20:00 ECS_Wood_vector-1.219feb2012.tar
-rw-r--r-- 1 bgt staff 686080 Mar 4 20:01 ECS__FIRS_vehicle_set-2014.11.26.tar
-rw-r--r-- 1 bgt staff 5294080 Mar 4 20:00 FIRS_Industry_Replacement_Set-1.4.5.tar
-rw-r--r-- 1 bgt staff 1280000 Mar 4 20:01 FISH_2-2.0.2.tar
-rw-r--r-- 1 bgt staff 1914880 Mar 4 20:01 FISH_ship_set-0.9.2.tar
-rw-r--r-- 1 bgt staff 30720 Mar 4 20:01 Finnish_Town_Names-1.0.tar
-rw-r--r-- 1 bgt staff 23613440 Mar 4 20:01 Finnish_Trainset-0.5.8.tar
-rw-r--r-- 1 bgt staff 30720 Mar 4 20:26 Hover_Bus-1.0.tar
-rw-r--r-- 1 bgt staff 92160 Mar 4 20:26 Hover_Vehicles-1.tar
-rw-r--r-- 1 bgt staff 2426880 Mar 4 20:01 Iron_Horse-1.8.0.tar
-rw-r--r-- 1 bgt staff 522240 Mar 4 20:00 Metro_Track_Set-2.1.2.tar
-rw-r--r-- 1 bgt staff 215040 Mar 4 20:00 OpenGFX_BigGUI-2.0.0.tar
-rw-r--r-- 1 bgt staff 788480 Mar 4 20:01 Sailing_Ships-0.62.tar
-rw-r--r-- 1 bgt staff 1259520 Mar 4 20:01 Swedish_Houses-1.1.2.tar
-rw-r--r-- 1 bgt staff 266240 Mar 4 20:01 Swedish_Trains-7.3.tar
-rw-r--r-- 1 bgt staff 163840 Mar 4 20:01 Trains_of_Europe_Generic-Alpha2.2.tar
-rw-r--r-- 1 bgt staff 92160 Mar 4 20:01 Vacuum_Tube_Train-0.22.tar
-rw-r--r-- 1 bgt staff 51200 Mar 4 20:01 Vacuum_Vehicle_Wagon_and_Train-0.22.tar
-rw-r--r-- 1 bgt staff 2498560 Mar 4 20:01 av8_Aviators_Aircraft_Set-2.21.tar
-rw-r--r-- 1 bgt staff 1116160 Mar 4 20:26 eGRVTS-1.0.tar
-rw-r--r-- 1 bgt staff 8550400 Mar 4 20:26 eGRVTS2-188.tar

This task depends upon

Closed by  andythenorth (andythenorth)
Wednesday, 30 August 2017, 19:56 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Frosch thinks this is likely a duplicate of FS#6322. Possibly an issue with AIs trying to allocate too much memory for 32 bit build with 32bit blitter.
Comment by Tomi "bgt" Suovuo (bgt) - Saturday, 12 March 2016, 17:59 GMT
This could be some kind of memory leak issue or such, as after reloading autosave7 the game continued well instead of crashing during the upcoming month. I do have a tendency of having the game run paused for days on on my computer. Hence a singe session will do numerous monthly autosaves.
Comment by qwertymain (qwertymain) - Thursday, 08 December 2016, 14:16 GMT
its a multiplayer?

Loading...