OpenTTD

Tasklist

FS#6424 - No Vehicles shown for railroad

Attached to Project: OpenTTD
Opened by Paul Robinson (rfc1394) - Wednesday, 24 February 2016, 16:52 GMT
Last edited by Alberth (Alberth) - Sunday, 28 February 2016, 08:31 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Critical
Priority Normal
Reported Version 1.5.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When clicking on a depot to create a train, no vehicles appear in the list. No engines, no cars, no anything, it's like all rail equipment has been deprecated. I thought maybe I had a buggy version (I was running some 1.4 release) that had lost thingz, but I upgraded to 1.5.3 and the problem is still present. This is not normal behavior, the game used to work fine, but now I can't create any rail vehicles.

I am running 64bit Windows 10 Pro (upgrade from 7), 16GB memory
This task depends upon

Closed by  Alberth (Alberth)
Sunday, 28 February 2016, 08:31 GMT
Reason for closing:  Not a bug
Comment by Paul Robinson (rfc1394) - Friday, 26 February 2016, 20:15 GMT
I even tried uninstalling and reinstalling OpenTTD but I still find railroads have no rolling stock at all.
Comment by 3298 (3298) - Saturday, 27 February 2016, 14:35 GMT
Working as intended. Normal rail vehicles become unavailable at some point around 2030. (Unless the "vehicles never expire" switch is enabled, of course.)
There are monorail (also expires, but a few years later) and maglev instead, use those.
Comment by Alberth (Alberth) - Sunday, 28 February 2016, 08:31 GMT
See also https://wiki.openttd.org/Railway_Construction#Types_of_railways how to select a different rail type.
Comment by Paul Robinson (rfc1394) - Monday, 29 February 2016, 13:00 GMT
Neither Monorail nor Maglev have coal cars. This looks like something is wrong. Also, when I was running the game the date was 1987, not 2030.
Comment by Paul Robinson (rfc1394) - Monday, 29 February 2016, 13:08 GMT
This save game is set from when I created a new game, in 1978. Railroads have no rolling stock at all, and neither does "Urban Monorail." I mean, I knoe it has worked in the past, I'm just not sure why it's not working now.
Comment by Alberth (Alberth) - Tuesday, 22 March 2016, 19:21 GMT
You use newgrfs, there is no rule that a trainset must provide rolling stock. If it only wants to provide engines, it may do so.
How or why is not something I can answer, you have to ask the author of the newgrf (or read its documentation perhaps?)

Similarly, newgrf can have different start and end years, maybe there is no engine provided in 1978 by the newgrfs that you use.

Loading...