OpenTTD

Tasklist

FS#6374 - Town road don't connect to player roads

Attached to Project: OpenTTD
Opened by 3iff (3iff) - Wednesday, 23 September 2015, 08:47 GMT
Last edited by frosch (frosch) - Friday, 30 October 2015, 17:22 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Originally tested using nightly 27325, retested in nightly 27403. WinXP SP3.
Originally mentioned in thread http://www.tt-forums.net/viewtopic.php?f=31&t=73720&p=1156905

Town roads won't grow to connect to owned roads. I surrounded a town with a road loop and set the game going with a small bus route to generate growth. The town never grew a road to touch my road loop. While this is a nice way to block town roads expanding, it does inadvertently block town growth when I simply build roads to connect my services. I don't recall towns doing this before.

In fact, from the screenshot, a town road will turn rather than connect to my road. The road layout is 3 * 3.

More testing using n27325 suggests that towns might connect to AI roads but never to my roads. However, I do think a town road grew from the other side of one of my through stations.

Screenshot and savegame using nightly 27403 and no grfs included.
This task depends upon

Closed by  frosch (frosch)
Friday, 30 October 2015, 17:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r27424
Comment by 3iff (3iff) - Wednesday, 23 September 2015, 12:26 GMT
Further investigation shows that the town won't make a T juction with my road but will extend my road in a straight direction. Also tested with nightly 27112 which shows the same behaviour.

Loading...