OpenTTD

Tasklist

FS#6371 - OOM Crash on OS X 10.10

Attached to Project: OpenTTD
Opened by shvgn (shvgn) - Wednesday, 09 September 2015, 23:41 GMT
Last edited by andythenorth (andythenorth) - Tuesday, 15 August 2017, 05:20 GMT
Type Bug
Category Core
Status Closed
Assigned To andythenorth (andythenorth)
Operating System Mac OS X
Severity High
Priority Normal
Reported Version 1.5.2
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Hi.

I was playing with my friends in multiplayer for several hours. All of us have 1.5.2 on different OS's. I catched OOM error, the game quitted.
OS X 10.10 Yoseimite
The game took more then 3 Gb as been shown in Activity Monitor.

Don't know whether it's high severity or not. I't the first crash in the first week of playing.
This task depends upon

Closed by  andythenorth (andythenorth)
Tuesday, 15 August 2017, 05:20 GMT
Reason for closing:  Unreproducible
Additional comments about closing:  I ran the savegame for a few years in single-player on 1.7.1 (macOS Sierra 10.12.5), no crash.

Chances of this getting diagnosed further by a developer (I am not a developer) are relatively low I'd guess, so I'm closing it. I'll keep an eye out for OOM on macOS in my games. Thanks for the report.
Comment by qwertymain (qwertymain) - Thursday, 08 December 2016, 14:22 GMT
the game is out of memory because the openttd only took max is 3.4GB but you took 3.55GB so openttd cant took 3.5GB over so you need expand your memory space to 8GB becuase i look you like use 4GB momory. i also crash with same reason in reddit server 1
Comment by shvgn (shvgn) - Thursday, 08 December 2016, 14:31 GMT
qwertymain, I cannot see how you made this conclusion. I had already had 8 Gb on my macbook by the first time i tried ottd.

Loading...