OpenTTD

Tasklist

FS#6358 - Clickboxes in Settings UI misaligned, when filter string applied

Attached to Project: OpenTTD
Opened by Rob Hailman (rjhelms) - Saturday, 08 August 2015, 19:41 GMT
Last edited by frosch (frosch) - Sunday, 09 August 2015, 10:23 GMT
Type Bug
Category Interface
Status Closed
Assigned To No-one
Operating System Windows
Severity Medium
Priority Normal
Reported Version 1.5.2-RC1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In the Advanced Settings UI, applying a filter string causes the clickboxes for all the settings to be misaligned with the display in the UI. This makes the UI very difficult to use.

This only occurs when a filter string is applied, and the category is set to something than "Expert" and the type is set to something other than "All". This leads me to believe that the issue is caused by the "Show to search all settings" text that appears in this case causing the display of the settings to move downwards, but not the clickboxes.

I have reproduced this in 1.5.2-RC1 and 1.5.1.

Steps to reproduce:

- Navigate to the Settings UI
- Apply a category other than "Expert"
- Enter a filter string, such as "station"
- Clickboxes are all a few pixels above where the settings actually display

- Set the category to "Expert"
- "Show to search all settings" text disappears, and clickboxes are now aligned with display
This task depends upon

Closed by  frosch (frosch)
Sunday, 09 August 2015, 10:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r27366
Comment by Alberth (Alberth) - Sunday, 09 August 2015, 06:46 GMT
I tried the above, but could not see any difference. Perhaps I am looking at the wrong thing? Perhaps I use a different font? I don't understand what "settings actually display" means here.

Could you please add some pictures demonstrating the problem (possibly enlarged as we seem to talk pixels here). Feel free to also add an image where you annotated what alignment is wrong (Also having an unedited version is useful to compare my display with your display pixel by pixel.)
Comment by frosch (frosch) - Sunday, 09 August 2015, 10:28 GMT
Happened, if the "+" and "-" buttons are taller than the font.

Loading...