OpenTTD

Tasklist

FS#635 - OpenTTD after closing sometimes doesn't "release" DirectSound driver

Attached to Project: OpenTTD
Opened by joeecz (joeecz) - Sunday, 18 February 2007, 01:55 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity High
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It happened two times, after unknown circumstances, everytime I run and play multiplayer game as a server for a long time.
After closing OpenTTD when I try to play a music for example in WinAmp it writes an error message: Bad DirectSound driver. In Windows MediaPlayer when I try to play a video it plays but no sound is heared.
After restarting the operating system (Windows XP SP 2), everything works properly.
When I try to catch "what and when" it causes I never get this problem, but I think it is caused by OpenTTD because I do nothing extraordinary (running other games or something...) before, during and after playing OpenTTD.
OpenTTD version 0.5.0 RC 5 (I never have had this problem before, it appears first time after running 0.5.0 version of OpenTTD as multiplayer server and play a game for hours... also never have this trouble with version 0.4.8)
This task depends upon

Closed by  Darkvater (Darkvater)
Monday, 26 February 2007, 10:08 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Well, glad to hear you found the cause :).

However you don't need to turn off the firewall, just open ports 3978/3979 for TCP & UDP.
Comment by Darkvater (Darkvater) - Friday, 23 February 2007, 11:16 GMT
That is really funny....you know why?
OpenTTD doesn't even use a DirectSound driver so I really doubt this would be it.
Comment by joeecz (joeecz) - Friday, 23 February 2007, 14:45 GMT
Maybe is mistake somewhere else, I try to collect more information and than post it here. I wrote DirectSound driver cause defaultly I use this driver in WinAmp and all players use it, but I try tu set a direct WaveOut output in WinAmp and it doesn't work also... and I have had no problem like this in past... so I think that there could be some bug with sound output, that hasn't been in 0.4.8 version. So, as I said, when I get more info I'll write.
Comment by Darkvater (Darkvater) - Friday, 23 February 2007, 16:07 GMT
When you restart OpenTTD after Winamp repeatedly says 'Bad DirectSound driver' does music/sound work there?
Because if it does OpenTTD can acquire the driver, so something else is the problem.

Have you checked that no zombie processes of OTTD are running? There have been no functional changes to the sound/music driver since 0.4.8
Comment by joeecz (joeecz) - Friday, 23 February 2007, 19:56 GMT
I found the problem now and you were right, it is not in OpenTTD. When I want to play OpenTTD via internet, I must turn off my firewall otherwise nobody can connect to my OpenTTD server. And after a while must someone somehow brake to my computer and the result is that all sounds stop working. Because I shut down firewall only while playing OpenTTD I thought that it was OpenTTD problem, but it isn't. Sorry for that.

Also, I would like to mention, that I have a litlle mess in reporting bugs especially with setting priority. I post another bug, which is much more serious, and it is really a BUG :) I have attached also a saved game in which the bug is occured. It is called: "Cargo from industries doesn't appear on adjacent stations". Please, look at it. Thank you for your time and sorry for my mistake again.

Loading...