OpenTTD

Tasklist

FS#6280 - Signals: adding a path signal while a train enter depot mess the pathfinder

Attached to Project: OpenTTD
Opened by romain (romazoon) - Thursday, 16 April 2015, 10:56 GMT
Last edited by andythenorth (andythenorth) - Thursday, 31 August 2017, 07:06 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 1.5.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

when a train is on it s way to a depot (only block signal were in use at moment i sent it to depot), but while it enter depot i added a path signal, the train then instantly stay locked in a "looking for free path" state, manually reversin the train fix the issue. (see scrennie)

I m not sure, but i believe i already reported that very same bug on Cirdan's version a couple month ago, and i m pretty sure he has fixed it since (just telling, in case you can use his code to fix that)

(test and screenies were made on a newgame created with OTTD 1.5.0 and, if it does matter, using windows 7)
This task depends upon

Closed by  andythenorth (andythenorth)
Thursday, 31 August 2017, 07:06 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Believe this is a duplicate of FS#6039, or at least same cause. May also be a subset behaviour of  FS#6045  .
Comment by andythenorth (andythenorth) - Thursday, 31 August 2017, 06:29 GMT
Replicated, haven't attached a save right now as I have unreleased newgrfs in my test case :x

Wasn't easy to trigger, but can be done building the layout in romazoon's screenshots (2 block signals), then adding a path signal over a 5 tile train as it enters the depot.

Loading...