OpenTTD

Tasklist

FS#6216 - TerraGenesis Variety Distribution bug

Attached to Project: OpenTTD
Opened by Nathan (Nathanxbox20) - Tuesday, 20 January 2015, 16:49 GMT
Last edited by andythenorth (andythenorth) - Sunday, 20 August 2017, 07:36 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version 1.5.0-beta1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

There is often a gridline-type error when generating new maps with TerraGenesis. The only variable that I have found to cause this bug is the variety distribution variable. The first I noticed this bug was with 1.5.0 beta. The bug is found in the upper right corner of the attached screenshot, and in several places in the attached save game.
This task depends upon

Closed by  andythenorth (andythenorth)
Sunday, 20 August 2017, 07:36 GMT
Reason for closing:  Unreproducible
Additional comments about closing:  Thanks for the report. Can't repro this in 1.6.1 or 1.7.1. Tried multiple combinations of height level, map size, terrain type, variety distribution, sea amount etc. No other reports of this, and it's a pretty noticeable issue when it occurs, so it's likely fixed by changes in TGP / MHL, or it's so rare that it's hard to trigger. Closing, thanks :)
Comment by Nathan (Nathanxbox20) - Tuesday, 20 January 2015, 16:52 GMT
Note: As the value of variety distribution increases, the occurrences and severity of the bug decreases, except when it is set to "None."
Comment by Alberth (Alberth) - Tuesday, 20 January 2015, 18:02 GMT
This looks really weird, I have never seen this happen.

In 1.5, the 'more heightlevels' (MHL) patch was added. As explained in  FS#6156  and http://www.tt-forums.net/viewtopic.php?f=33&t=72107 there are still some problems with it.
Before the 1.5 release, either the MHL patch will be removed, or it will be fixed.

In the former case, this problem would disappear by itself, since we'd go back to the situation of 1.4
In the latter case, the MHL fixes may also fix this problem. For this reason, I suggest to first wait for the fix of  FS#6156 . Perhaps after that, you can try again to see if the problem got solved as well?

Comment by Nathan (Nathanxbox20) - Wednesday, 21 January 2015, 01:10 GMT
In addition, I have only noticed the bug when the terrain type is set to Flat or Very flat. Otherwise, the variety distribution variable works normally. Temporary fix: set variety distribution to None when playing with terrain type set to Flat or Very Flat.

Loading...