OpenTTD

Tasklist

FS#5938 - Refit costs are not running costs

Attached to Project: OpenTTD
Opened by Martin Bruzina (megaloman) - Friday, 07 March 2014, 23:37 GMT
Last edited by andythenorth (andythenorth) - Monday, 21 August 2017, 18:25 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 1.4.0-beta4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

How to reproduce:
Refit any vehicle with non-zero cost of refit. For example: 1.4.0-beta4 -> Start new game -> Build new train depot -> Buy new SH'125' -> Refit to any cargo.

Expected behavior:
Company Finances Window -> Costs of refit are included in "New Vehicles".

Actual behavior:
Company Finances Window -> Costs of refit are included in "Running Costs".
This task depends upon

Closed by  andythenorth (andythenorth)
Monday, 21 August 2017, 18:25 GMT
Reason for closing:  Won't implement
Additional comments about closing:  This is not a current goal for OpenTTD. Flyspray clean up, so closing this. Thanks for the suggestion :)
Comment by Alberth (Alberth) - Saturday, 08 March 2014, 10:24 GMT
What about having refit orders in the regular order list? A train that is 5 years old getting refitted for a different cargo, is that a "new vehicle"?
Also, what if refitting happens in the station itself (ie auto-refit)? The train then never visits the depot (for refitting, at least).
Comment by EthanG (EthanG) - Tuesday, 25 March 2014, 11:25 GMT
I don't agree refit costs should be listed as new vehicle costs, but listing refit costs as running costs is terrible! I've gone off using newgrfs because I tried to work with these listed "running costs" and the numbers just didn't add up. It's so confusing!
Comment by Helge Hafting (hafting) - Monday, 31 March 2014, 09:07 GMT
Refit as a "running cost" makes sense in some cases. Using FIRS, I can have a train transporting oil one way and milk on the return trip - using the same tanks. Then there will be a refit cost on every trip - which seems very much like a "running cost" to me.

Ideally, such automatic refitting would be "running costs" and refitting by the player could be "new vehicle cost". Especially if the vehicle has not been used yet.

Comment by EthanG (EthanG) - Monday, 31 March 2014, 12:29 GMT
Those are things players can work out for themselves very easily, but if refit is bundled with new vehicle or running costs, they're not so easy to separate are they?

If I sound snippy, there's a reason. Yesterday another program reminded me that reducing the number of different elements in a UI can be a very stupid thing to do, leading to far more confusion than is necessary. The problem in that other program was options which appear related but which obey different rules. This issue OpenTTD is not even a matter of things which seem related, it's just gratuitously trying to reduce the number of lines. Stop being confusing.

Loading...