OpenTTD

Tasklist

FS#5701 - Old AI version selected after upgrading AI and starting a new game

Attached to Project: OpenTTD
Opened by Kogut (Kogut) - Thursday, 08 August 2013, 16:32 GMT
Last edited by andythenorth (andythenorth) - Thursday, 31 August 2017, 08:10 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Note, I am unable to reproduce this bug (sorry) but I confirmed that it happens.

r25700

See http://www.tt-forums.net/viewtopic.php?p=1087591#p1087591 - somebody else also had this problem.
This task depends upon

Closed by  andythenorth (andythenorth)
Thursday, 31 August 2017, 08:10 GMT
Reason for closing:  Unreproducible
Additional comments about closing:  No info since 2013. Flyspray clean up, so closing. Re-open if the issue is reported again. Thanks.

Possibly related to FS#6468.
Comment by Remko Bijker (Rubidium) - Tuesday, 12 November 2013, 21:18 GMT
  • Field changed: Status (New → Unreproducable)
After rescanning the AIs, the configuration is reset. Normally it would force the version if a game is loaded, but in the main menu it uses the one with the highest version number.

In other words, I'm not seeing where in the code it would be doing the wrong thing (tm). Except maybe that it might not have detected the AI for some odd reason outside of the control of OpenTTD.

Loading...