OpenTTD

Tasklist

FS#5682 - Override behaviour second 18h tile oil rig

Attached to Project: OpenTTD
Opened by George (George) - Monday, 29 July 2013, 16:45 GMT
Last edited by andythenorth (andythenorth) - Friday, 01 September 2017, 07:38 GMT
Type Feature Request
Category NewGRF → NewStations
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

r25610

A station from default oil rig (tile 18) accepts cargo even if the industry and its' tiles do not accept cargo.
This station should (as other stations) check, that there are tiles which accept cargo. In case all the tiles do not accept cargo it should accept cargo too.
This causes the following issue for ECS oil rig and ECS fishing ground: passengers are uploaded into water (industry does not accept cargo, while the station does).
This task depends upon

Closed by  andythenorth (andythenorth)
Friday, 01 September 2017, 07:38 GMT
Reason for closing:  Won't implement
Additional comments about closing:  The oil-rig station tile has multiple anomalous behaviours, and won't be changed or made more extensible. As per my comment 25th August 2017 here, we should provide buoy stations, or similar, as an alternative to stations built into industries. See FS#4792 for that.

Flyspray clean up, this one won't be implemented, as issue needs solved differently, so closing. Thanks.
Comment by frosch (frosch) - Monday, 29 July 2013, 20:27 GMT
There is nothing special about oilrig stations. The behaviour is already like you request.
Use the tile info tool to find the tiles which cause the acceptance. Either your industry is buggy, or there are other tiles nearby.
Comment by George (George) - Monday, 05 August 2013, 07:20 GMT
As you can see, OIL rig tiles nor oil rig itself does not accept passengers, while the station accepts passengers and a ship unloads passengers.
The station should not accept passengers, because industry tiles do not accept passengers and there is nothing around that can accept anything.

NOTE: a typo in Details text "In case all the tiles do not accept cargo it(station) should NOT accept cargo too."
Comment by Remko Bijker (Rubidium) - Tuesday, 12 November 2013, 16:19 GMT
There is one tile that still accepts passengers. The other tiles seem to lose their acceptance when the max becomes red.
Comment by Remko Bijker (Rubidium) - Monday, 18 November 2013, 21:16 GMT
  • Field changed: Type (Bug → Feature Request)
  • Field changed: Summary (Station inside oil rig accepts cargo even when industry not → Override behaviour second 18h tile oil rig)
  • Field changed: Severity (High → Medium)
For an oil rig you need two 18h tiles for it to get the station. One of them remains and that can't be overridden to provide other behaviour. As such, the passenger acceptance of that tile will always remain.

To remedy this there should be some way to override the behaviour of that second 18h tile, or some other way to tell where the station part has to come.
Comment by andythenorth (andythenorth) - Saturday, 12 August 2017, 17:36 GMT
Confirmed - replicated this with FIRS.
Comment by andythenorth (andythenorth) - Friday, 25 August 2017, 10:45 GMT
I would solve this a little differently.

1. Leave the oil rig built-in station alone. It's there, and works for the very special case of wanting to route ships and land helicopters on a water-based industry. Be nice if the station grabbed it's name from the industry, but eh.
2. Provide buoy stations per FS#4792, removing the need for industries like fishing grounds to provide a station. Buoy stations would be for ships only, not helicopters. Any requirement to handle helicopters on water could be met in some enhanced airports in future.

Loading...