OpenTTD

Tasklist

FS#5518 - crash in follow_track.hpp

Attached to Project: OpenTTD
Opened by Ingo von Borstel (planetmaker) - Monday, 01 April 2013, 18:39 GMT
Last edited by Remko Bijker (Rubidium) - Monday, 01 April 2013, 21:19 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Assertion failed at line 125 of /home/openttd/svn-publicserver/src/pathfinder/npf/../follow_track.hpp: ((TrackStatusToTrackdirBits(GetTileTrackStatus(m_old_tile, TT(), IsRoadTT() && m_veh != NULL ? RoadVehicle::From(m_veh)->compatible_roadtypes : 0)) & TrackdirToTrackdirBits(m_old_td)) != 0) || (IsTram() && GetSingleTramBit(m_old_tile) != INVALID_DIAGDIR)

Happening on Publicserver r25130 with attached savegame. The autosave is from slightly before that crash.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Monday, 01 April 2013, 21:19 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Of  FS#5510  / FS#5516 
Comment by Transportman (Transportman) - Monday, 01 April 2013, 20:41 GMT
That should be fixed in r25132, see also #5516 and #5510.

That said, I also still encounter the bug with the latest nightly in my own game (also in this game) when trying to remove stations, but that is a game in which the warranty has been voided (and I miss some NewGRFs from your game).

For the dev that is going to work on this ticket: In the saves in this bug it happens when trying to remove the station near Slundworth/Senfingfield Valley.
Comment by Remko Bijker (Rubidium) - Monday, 01 April 2013, 21:19 GMT
This is a bit cause-and-effect-ish.

The crash of  FS#5510 ,  FS#5516  and  FS#5518  is caused by a stray reservation. This stray reservation is solved by r25132. The crash (or rather assertion) because of the stray reservation is not resolved since that won't trigger unless there is a stray reservation, which is the real bug. As such, savegames that are already affected by the bug, thus having stray reservations, will still remain to crash.
Comment by Transportman (Transportman) - Tuesday, 02 April 2013, 16:44 GMT
Is it possible to somehow remove the stray reservation or is it unfixable and players should just leave the tile involved?

Loading...