OpenTTD

Tasklist

FS#5444 - Main window slip to the top corner, no way to show other part

Attached to Project: OpenTTD
Opened by Jack² (Jack_II) - Friday, 18 January 2013, 17:40 GMT
Last edited by andythenorth (andythenorth) - Sunday, 20 August 2017, 06:43 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 1.2.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi
Very strange bug.
During my keyboard touch or mouse, I have certainly clicked or composed a special sequence that generate this problem :
The main window begin to slip from the point I am at to the up corner of the map.
An additionnal mouse-click or keyboard Enter key change nothing. The main window is locked to this corner.
I have saved and exited from the game, and the problem is still there when I join back the same game !
No more problem with a new game.
Very funny.
This task depends upon

Closed by  andythenorth (andythenorth)
Sunday, 20 August 2017, 06:43 GMT
Reason for closing:  Unreproducible
Additional comments about closing:  No ability to repro. Tar pit. Issues like this have a low chance of getting solved as diagnosing them is remarkably difficult.

Cleaning Flyspray, so closing this one.
Comment by Alberth (Alberth) - Saturday, 19 January 2013, 21:05 GMT
With Linux, after loading the game, I can move back to other parts of the map with mouse or with keys, like usual. I tried a recent trunk as well as the 1.2.3 binary.

It looks like a windows-only bug.
Comment by Alberth (Alberth) - Saturday, 19 January 2013, 21:49 GMT
 FS#5381  on the other hand has similar symptoms. What type of video card do you use?
Comment by Jack² (Jack_II) - Sunday, 20 January 2013, 00:39 GMT
I reopen the save game today and the problem no more present.
You'r right, may be Windows.
Note that the Windows session is the same than friday - this machine restarts rarely (W7-64).


Comment by Jack² (Jack_II) - Sunday, 20 January 2013, 00:45 GMT
My video card is a "ATI Radeon HD 5800 Series" and I use two screens in full HD mode.

Note a special thing :
This machine use UltraVNC server to be connected from outside.
UVNC use a video hooking.
The driver version is "UVNC BVBA" v6.0.1.0 on 4 nov 2007
Seems to be the lastest version.

If the problem reappears, I'll test to deactivate this driver/function.
Comment by Ingo von Borstel (planetmaker) - Tuesday, 12 February 2013, 13:45 GMT
I've seen such behaviour on OSX. But in a fashion that I can't reliably reproduce it. And such that exiting OpenTTD and re-starting, sometimes repeatedly in an attempt to pin-point it, it solved it. So it might still be different, especially as it's another OS ;-)
Comment by Remko Bijker (Rubidium) - Thursday, 14 November 2013, 20:02 GMT
Also happened to me. Tried to add code to debug it, but never got far enough as the issue is spurious at best.
Comment by andythenorth (andythenorth) - Sunday, 20 August 2017, 06:44 GMT
FWIW, I've seen the issue multiple times on OS X, and no obvious pattern to it.

Loading...