FS#5100 - [OSX] Openttd 1.1.5 on mac os x 10.6.8 crashes when ai starts up

Attached to Project: OpenTTD
Opened by eugene (eugene88) - Tuesday, 13 March 2012, 16:29 GMT
Last edited by frosch (frosch) - Saturday, 17 March 2012, 12:53 GMT
Type Bug
Category Script → NoAI
Status New
Assigned To No-one
Operating System Mac OS X
Severity High
Priority Normal
Reported Version 1.1.5
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No


Hi, I running openttd 1.1.5 on mac os x 10.6.8. The problem is whenever AI starts, the game crashes. I tried AdmiralAI, NoCAB, PaxLink, Clueless. In the case of Admiral, the warning that the game will shut down, popped up. In the case of other AIs, the game simply crashes.
This task depends upon

Comment by Ingo von Borstel (planetmaker) - Tuesday, 13 March 2012, 17:33 GMT
Then please provide the crash information as you should have been asked to provide (crash.log, crash.sav, crash.png). Without further information we cannot reproduce this as this clearly is not the case for the vast majority of people who use it (including myself).
Comment by eugene (eugene88) - Tuesday, 13 March 2012, 17:50 GMT
Sorry, I thought that I attached the files!
Comment by Ingo von Borstel (planetmaker) - Tuesday, 13 March 2012, 18:27 GMT
Thanks. Unfortunately the stacktrace is a bit inconclusive. Can you quote verbatim (or via screenshot) the warning that the game will shut down when using AdmiralAI? Does this maybe happen when you (un)hide the game while using the fullscreen mode?
Comment by eugene (eugene88) - Tuesday, 13 March 2012, 18:39 GMT
Here is a screenshot when the games warns about quitting, a screen shot of problem report, and a copy of Problem details in crash.rtf. I am not running the game in a fullscreen mode.
Comment by Soul Fairer (soulfairer) - Sunday, 11 November 2012, 15:25 GMT
This trace is also inconclusive. "Bus error" may not have to do with OpenTTD. Did the crash occur afterwards?
Comment by Ezra Cooper (ezrakilty) - Saturday, 29 December 2012, 04:04 GMT
Under MacOS X 10.6.8, I opened this savegame in OpenTTD 1.1.0, 1.1.5 and 1.2.0 and didn't have any problems. I ran it for long enough to let one or two AIs start up.

I wonder if the problem could be with some NewGRF or some MacOS system modification?
Comment by Remko Bijker (Rubidium) - Sunday, 17 November 2013, 21:28 GMT
Looks like  FS#5606