Website

All pending tasks and bugs related to the website.
Tasklist

FS#5015 - No direct file link to binaries.openttd.org

Attached to Project: Website
Opened by Charles Pigott (LordAro) - Friday, 27 January 2012, 23:54 GMT
Last edited by Patric Stout (TrueBrain) - Saturday, 28 January 2012, 11:19 GMT
Type Bug
Category Backend
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 1.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

while trying to develop auto update script for stable releases, wget-ing to the following url results in a 404:
http://binaries.openttd.org/binaries/releases/1.1.5/openttd-1.1.5-linux-generic-i686.tar.xz

this can obviously be circumvented by directly linking to a mirror (e.g. gb) but is not desired

This also holds true for trunk

I consider this a bug, as it used to work :)
and, oddly, wget-ing to a nightly build seems to work (307-ing through to correct mirror)

example in attached bash script
This task depends upon

Closed by  Patric Stout (TrueBrain)
Saturday, 28 January 2012, 11:19 GMT
Reason for closing:  Not a bug
Comment by Patric Stout (TrueBrain) - Saturday, 28 January 2012, 11:19 GMT
You cannot just replace a link you got from a mirror, and remove the language code, and hope the URL works :)

The "used to work" is false, as that link never worked. The correct link should be:

http://binaries.openttd.org/releases/1.1.5/openttd-1.1.5-linux-generic-i686.tar.xz

(so your link minus the /binaries). Some mirrors do add an extra directory, or change the URL completely, but that is how the mirror works.

With that, it is also not odd that the nightly works, as there you did not add /binaries :)

Loading...