OpenTTD

Tasklist

FS#4722 - Company Password not working right

Attached to Project: OpenTTD
Opened by KyleZ (Shoomfie) - Friday, 12 August 2011, 07:01 GMT
Last edited by frosch (frosch) - Saturday, 13 August 2011, 08:33 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 1.1.2-RC2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I create a company password in a multiplayer game, I can't join it on another computer because it says "incorrect password". Even when I'm 100% sure that I typed in the password right.
This task depends upon

Closed by  frosch (frosch)
Saturday, 13 August 2011, 08:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r22738
Comment by Remko Bijker (Rubidium) - Friday, 12 August 2011, 15:01 GMT
I can't reproduce this. It works perfectly fine for me. Given the lack of other people complaining

The things I can think of that have happened:
- the server owner changed the password
- someone else changed the password
- caps lock or similar was turned on when entering the password (either when setting or when joining)
- a typo has been made (either when setting or when joining)
Comment by KyleZ (Shoomfie) - Friday, 12 August 2011, 17:47 GMT
first off... thank you for your very prompt investigation into this matter. I was afraid that this project might be nearly dead. Anyway, I'm posting some pics of what's happening to make it a little easier to see what my problem is.

- I'm the Server Owner
- I owned the company on my desktop
- No-one else had the password
- Caps lock was off
- no typos.

Would newGRF have anything to do with this problem? I'm only running a couple vehicle mods, and some of the ECS mods.

Thanks for your time.
   1.bmp (1.02 MiB)
   2.bmp (960.1 KiB)
   3.bmp (960.1 KiB)
   4.bmp (960.1 KiB)
Comment by frosch (frosch) - Saturday, 13 August 2011, 07:51 GMT
  • Field changed: Status (Unreproducable → Confirmed)
Broken in r21854.

It is reproducible when the server is not dedicated and the password is set on the server.

Loading...