OpenTTD

Tasklist

FS#4691 - not every industry is available in SE while available in new game

Attached to Project: OpenTTD
Opened by George (George) - Wednesday, 20 July 2011, 20:54 GMT
Last edited by frosch (frosch) - Friday, 29 July 2011, 22:23 GMT
Type Bug
Category NewGRF → NewIndustries
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

R22637

http://www.tt-forums.net/viewtopic.php?f=26&t=30188&start=1600#p958250

Steps to reproduce:
- save the NewGRFs as preset from the scenario FLC provided.
- activate that preset and start the scenario editor
- look at the available industries. It's the same thing.
Note: if you start a new game instead of SE, all industries are present.

the list of available industries in SE is shorter, than in a new game.
This task depends upon

Closed by  frosch (frosch)
Friday, 29 July 2011, 22:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r22693
Comment by Remko Bijker (Rubidium) - Monday, 25 July 2011, 19:28 GMT
No matter how hard I try, I can't reproduce this in r22688 with the given steps. Except when "restarting" that particular broken game.

In both the scenario editor and new games I get ~30 industries with the preset from the savegame.
Comment by frosch (frosch) - Friday, 29 July 2011, 20:46 GMT
The industry override manager is filled with FIRS industries. All 64 slots are allocated, so there is no room for more industry types, thus some are missing.

However, the gamelog states that no GRFs were added after the scenario was created. So there must be some way to create a new scenario without resetting the override manager.
Comment by frosch (frosch) - Friday, 29 July 2011, 20:55 GMT
Looks like the override manager is not reset at all when starting a scenario. So to reproduce the bug.
1. Start OpenTTD.
2. Activate FIRS-
3. Enter scenario editor-
4. Leave scenario editor-
5. Remove FIRS from NewGRF config and add ECS vectors instead.
6. Enter scenario editor again-

Loading...