OpenTTD

Tasklist

FS#4642 - Crash after loading a savegame

Attached to Project: OpenTTD
Opened by Brumi (Brumi) - Monday, 13 June 2011, 19:41 GMT
Last edited by frosch (frosch) - Saturday, 02 July 2011, 21:21 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 1.1.1
Due in Version 1.1.2
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

OpenTTD crashes after loading the attached savegame. Previously I was able to open it, with one of the versions from the 1.0.x branch.
I cannot check it with the current nightly now, as its download link doesn't work on openttd.org, giving me error 404...
This task depends upon

Closed by  frosch (frosch)
Saturday, 02 July 2011, 21:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r22625
Comment by Remko Bijker (Rubidium) - Monday, 13 June 2011, 21:19 GMT
  • Field changed: Status (New → Confirmed)
  • Field changed: Due in Version (Undecided → 1.1.2)
For some reason the jet trying to blow up an UFO exists, but the UFO doesn't anymore. But by the looks of it it already blew up the UFO; UFO at 14516, NE of that there's a bit of cleared land near the water..

At the moment I've got no idea what is the cause of it, though at worst we could detect this in the savegame loading and fix it I'd say.
Comment by frosch (frosch) - Saturday, 02 July 2011, 21:11 GMT
The loading of current_order of diaster vehicles is totally broken. It is zeroed for all disaster vehicles when loading games from 1.0.

Thus the ufo destroyer reverts back to the first order "destroy ufo", though it was already at the "leave map" order.

Loading...