OpenTTD

Tasklist

FS#4622 - Bugs when importing an original TT savegame

Attached to Project: OpenTTD
Opened by Jubilee (Jubilee) - Sunday, 22 May 2011, 07:47 GMT
Last edited by frosch (frosch) - Sunday, 03 July 2011, 10:59 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version 1.1.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

When loading the attached Original TT savegame, the following things happen:

- After loading the game in OpenTTD, the user must manually change all the servicing intervals because they are all set to disabled (instead of the defaults for each vehicle type), causing all vehicles to eventually drop down to 0% in reliability.

- Some train wagons are not properly translated (i.e. Train 4 is composed of coal trucks but in the train info panel they show as mail vans, while in the capacities they show as carrying coal). Cloning the train produces mail vans. In another train (train 12), the mail vans are wrongly shown as coal trucks in the info panel, even though in the capacities they are shown as carrying mail.
This task depends upon

Closed by  frosch (frosch)
Sunday, 03 July 2011, 10:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r22626 (the service interval issue)
Comment by Zdeněk Sojka (SmatZ) - Sunday, 22 May 2011, 18:37 GMT
  • Field changed: Status (New → Confirmed)
Mail wagons are loaded as coal ones as well, strange.
Comment by Jubilee (Jubilee) - Sunday, 22 May 2011, 20:03 GMT
  • Field changed: Percent Complete (100% → 0%)
Thanks for the fix, but there's no comment for the following:

"After loading the game in OpenTTD, the user must manually change all the servicing intervals because they are all set to disabled (instead of the defaults for each vehicle type), causing the reliability of all vehicles to eventually drop down to 0%."

I assume there's no fix about it, right?
Comment by frosch (frosch) - Sunday, 22 May 2011, 20:05 GMT
Haha, yeah, that's what you get for putting two things in one task :p Sorry :)

Wrt. the first issue: _old_vds is never initialised when loading TTD or TTO savegames.
Loading a 0.7.x savegame first and the loading a TTO/TTD savegame makes it use of the company settings from the 0.7.x game.
Comment by Jubilee (Jubilee) - Sunday, 22 May 2011, 20:30 GMT
>> Haha, yeah, that's what you get for putting two things in one task

Yup, i thought of that after i had posted the task. :) Sorry for it.

Comment by Jubilee (Jubilee) - Friday, 03 June 2011, 08:54 GMT
OpenTTD 1.1.1

"After loading the game in OpenTTD, the user must manually change all the servicing intervals because they are all set to disabled (instead of the defaults for each vehicle type), causing all vehicles to eventually drop down to 0% in reliability."

This seems to have been resolved. Thanks.

"Some train wagons are not properly translated (i.e. Train 4 is composed of coal trucks but in the train info panel they show as mail vans, while in the capacities they show as carrying coal). Cloning the train produces mail vans. In another train (train 12), the mail vans are wrongly shown as coal trucks in the info panel, even though in the capacities they are shown as carrying mail"

This one still exists. Train 4 for instance should have coal cars but instead in the train info, it seems to have mail vans. I thought this one was fixed... :(
Comment by Jubilee (Jubilee) - Friday, 03 June 2011, 08:59 GMT
Sorry, my mistake. Both issues are unresolved in 1.1.1...
Comment by Thijs Marinussen (Yexo) - Friday, 03 June 2011, 18:25 GMT
The commit that fixed that (r22498: - Fix: Engine IDs for coal and mail wagons were swapped in the TTO savegame conversion) was not backported to 1.1.1. It should be fixed in trunk and the fix will also be in the upcoming 1.1.2-RC1 release.

Was the servicing interval bug fixed at all? I thought that was the reason this bug report is still open.
Comment by frosch (frosch) - Friday, 03 June 2011, 18:58 GMT
Yexo is correct. The service interval is not fixed yet, thus the task is still open.
Comment by Jubilee (Jubilee) - Saturday, 04 June 2011, 05:45 GMT
No,it wasn't. My mistake. The service interval on the info of each train is the usual 150 days, that's why i got tricked and thought it was fixed. If you go in Options, all service intervals of all vehicle types are still set to "disabled".

Sorry about the re-reports. I thought that when a bug was marked as "fixed", it would be included in the next release. I didn't know the process.

Loading...