OpenTTD

Tasklist

FS#4617 - OpenTTD icon not shown in title bar

Attached to Project: OpenTTD
Opened by Charles Pigott (LordAro) - Monday, 16 May 2011, 20:47 GMT
Last edited by Remko Bijker (Rubidium) - Friday, 09 September 2011, 09:14 GMT
Type Bug
Category Build system
Status Closed
Assigned To No-one
Operating System Linux
Severity Very Low
Priority Normal
Reported Version 1.1.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I think this is a feature request, rather than a bug...

Ubuntu (9.10-)11.04

See pictures. I think that the logo should be displayed, like it does like for other applications (firefox, chromium for example)
This task depends upon

Closed by  Remko Bijker (Rubidium)
Friday, 09 September 2011, 09:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r22910
Comment by Jake (EmperorJake) - Friday, 02 September 2011, 05:07 GMT
The Windows version running under WINE does display the logo (however it has reduced performance). It would be nice if this worked.
Comment by frosch (frosch) - Friday, 02 September 2011, 18:47 GMT
The logo works fine for me on debian.
Are you using a Ubuntu binary from openttd.org, or one from the Ubuntu package manager?
Comment by Charles Pigott (LordAro) - Monday, 05 September 2011, 09:54 GMT
i use a script to update, which should download the generic linux binaries from openttd.org
Comment by frosch (frosch) - Monday, 05 September 2011, 17:47 GMT
  • Field changed: Type (Feature Request → Bug)
  • Field changed: Summary (Ubuntu title-bar logos? → OpenTTD icon not shown in title bar)
  • Field changed: Status (New → Confirmed)
  • Field changed: Category (Interface → Build system)
sdl_v.cpp loads the icon from "openttd.32.bmp".
The bundle only includes .xpm and .png though.
Comment by frosch (frosch) - Monday, 05 September 2011, 19:33 GMT
It's actually worse. sdl_v.cpp searches only in the "media" subdirectory of the current working directory. So it even only works when starting ottd from the repository root.
Comment by Charles Pigott (LordAro) - Friday, 09 September 2011, 11:26 GMT
yay! :)
that also explains why it was working on my compiled versions, as (to be quicker) i run './bundle/openttd'
thanks rubidium

Loading...