OpenTTD

Tasklist

FS#4491 - Bug Reporting - Improved or Automated

Attached to Project: OpenTTD
Opened by MinchinWeb (MinchinWeb) - Wednesday, 09 February 2011, 15:12 GMT
Last edited by andythenorth (andythenorth) - Thursday, 17 August 2017, 15:36 GMT
Type Feature Request
Category Core
Status Closed
Assigned To andythenorth (andythenorth)
Operating System All
Severity High
Priority Normal
Reported Version 1.0.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I was playing OpenTTD and the game crashed. I thought I would help the community by submitting a bug/crash report. However, the process proved rather long and complicated. Is there not some way this could be automated, or at least greatly simplified??

I consider myself rather computer savy, but it took me 20+ minutes to submit the bug report. FYI, I'm using Window 7 x64 and Chrome. Here's the steps I had to complete:
1. Figure out what the crash screen was telling me.
2. Open up Chrome.
3. Manually type the URL (bugs.openttd.org) (at least the URL is relatively simple...)
4. Stare at the page, not finding anything that says 'Report Bug' or the like
5. Click on 'Register'
6. Taken to a different webpage (that I have to assume is related to the first page) and asked to fill in a bunch of information, including coming up with another password
7. Go dig up my email and find the verification email
8. Click on the verification link
9. Go back to the first webpage (bugs.openttd.org)
10. Click 'Log in' and then wonder why nothing happens
11. Try 'Log in' again
12. Apparently this webpage you enter your username and password on the front page. Log in for real.
13. Look for 'Report Bug'... nothing ... 'Add New Tasks'??
14. Type up the bug report (finally)
15. Find the five requested files on my computer upload them. Note that 'crash.dmp' won't upload while OpenTTD's crash dialog remains open (I get an error 'File open with another program')
16. Submit bug report!


Perhaps the model is Firefox - if it crashes, it brings up a box that asks you 'What were you doing?' and has a submit button right there.

Thanks for the great game!
This task depends upon

Closed by  andythenorth (andythenorth)
Thursday, 17 August 2017, 15:36 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Per comment by Rubidium, bug reports are not automated by design.

Flyspray clean up: more than 5 years old, and not obvious what should be done with this next, so closing. If this offends, discuss with andythenorth in irc. Thanks.
Comment by Remko Bijker (Rubidium) - Thursday, 10 February 2011, 10:29 GMT
We once had such a system, but in most cases we still had to ask the reporter something after we got the initial data. When we don't have any contact information we can't figure out the cause, which would mean being flooded with many unsolvable bugs due to too little information being available.

Also, for a computer it's very hard to see whether there is any resemblence with another bug report, an user might be better suited to see whether the bug is already reported.

Even then, many bug reports don't belong in this tracker; e.g. they are made with a custom build. Having them automagically been dumped on our tracker isn't something I would fancy at all.

Loading...