OpenTTD

Tasklist

FS#4212 - Installer doesn't report any error when it can't replace file

Attached to Project: OpenTTD
Opened by Pereyaslov Konstantin (perk11) - Monday, 08 November 2010, 08:42 GMT
Last edited by Loïc GUILLOUX (glx) - Thursday, 11 November 2010, 17:06 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Medium
Priority Normal
Reported Version 1.0.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I ran installer of 1.0.4 while 1.0.2 was running. Installer reported no errors, but the file openttd.exe (and maybe some other files) was not replaced by the new version, but installer showed that install is successful. So after I tried to run it, I got error 'No language packs available'.
This task depends upon

Closed by  Loïc GUILLOUX (glx)
Thursday, 11 November 2010, 17:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r21146.
Comment by Jean-Francois Claeys (Belugas) - Tuesday, 09 November 2010, 02:51 GMT
Why, in the Name of Hell's Gate Keeper are you running BOTH INSTALLERS?????
What is is that you would expect from such a strange (to say the least) behaviour?
Comment by Pereyaslov Konstantin (perk11) - Tuesday, 09 November 2010, 05:31 GMT
I was running openttd 1.02 and installer 1.04, not both installers
Comment by Jean-Francois Claeys (Belugas) - Tuesday, 09 November 2010, 14:55 GMT
Ok, my bad, your report lead me to confusion.
But still... You really should have close openttd 1.0.2 before running installer 1.0.4
And have you tried to re-run the installer?
Or maybe de-install everything and re-run 1.04?

Loading...