OpenTTD

Tasklist

FS#4176 - Ability to over-expand boxes

Attached to Project: OpenTTD
Opened by Moriarty (Moriarty) - Friday, 22 October 2010, 16:13 GMT
Last edited by Loïc GUILLOUX (glx) - Saturday, 23 October 2010, 17:38 GMT
Type Bug
Category Interface
Status Closed
Assigned To No-one
Operating System Windows
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r21003 on Windows XP

I'm running the game in a maximised window rather than full screen. The bug is that the game allows you to expand extensible dialogs below the actual game-window, meaning as soon as you let go, you can't shrink the dialog again because the drag-icon is off-screen. See screenshot. The only way to "fix" these windows is to switch to fullscreen mode.

Suggested solution: It should not be possible to make a box larger than the game window in either the X or Y.
This task depends upon

Closed by  Loïc GUILLOUX (glx)
Saturday, 23 October 2010, 17:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r21015.
Comment by Alberth (Alberth) - Saturday, 23 October 2010, 09:54 GMT
At my Linux system, I cannot reproduce the issue, the GUI grows until the mouse leaves the window. It does not seem possible to make it so large that the drag button disappears completely.
Comment by AnthonyVDG (avd) - Saturday, 23 October 2010, 14:54 GMT
The issue is not about resizing the windows inside openttd, but about the openttd window itsself. Imo there should be an extra check that the windows are not bigger than that of the openttd window (when the openttd window has been resized), so it would be impossible to reproduce such issues.

I could it reproduce here, and I think that isn't an os issue at all.

Edit: The extra checks could create new problems when a user decides to resize the main openttd window too small (smaller then the minimum size of the windows inside openttd). This can be solved by a) raising the minimumsize or b) not resizing the widgets if they are smaller then a given size (for example the biggest minimumsize of the windows inside openttd available).
Comment by Remko Bijker (Rubidium) - Saturday, 23 October 2010, 15:52 GMT
  • Field changed: Status (New → Confirmed)
  • Field changed: Operating System (All → Windows)
In Windows you can drag an in-game window to become bigger than the actual window of OpenTTD. It has, unlike avd's suggestion, nothing to do with resizing OpenTTD's window.

Loading...