OpenTTD

Tasklist

FS#4043 - Scroll buttons flickers

Attached to Project: OpenTTD
Opened by AnthonyVDG (avd) - Tuesday, 17 August 2010, 14:26 GMT
Last edited by Remko Bijker (Rubidium) - Friday, 20 August 2010, 11:55 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version Version?
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

How to reproduce: press an arrow on a scrollbar

What do you see: the button flickers

What did you expect: the button should be pressed
This task depends upon

Closed by  Remko Bijker (Rubidium)
Friday, 20 August 2010, 11:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r20577
Comment by AnthonyVDG (avd) - Tuesday, 17 August 2010, 14:27 GMT
Forgot to mention that the bug occurred in r20525 and stable version 1.0.3,

Forgot also to mention that it occurs when keeping the button pressed
Comment by AnthonyVDG (avd) - Tuesday, 17 August 2010, 15:03 GMT
It seems that it affects almost every button that allows you to press for a long time.

I think it has something to do with the way DispatchLeftClickEvent (window.cpp) is called. It seems to be called multiple times if the mouse is pressed for a long time.

Loading...