OpenTTD

Tasklist

FS#4022 - Docks won't add to existing station

Attached to Project: OpenTTD
Opened by energetic2 (energetic2) - Tuesday, 10 August 2010, 06:13 GMT
Last edited by Remko Bijker (Rubidium) - Tuesday, 10 August 2010, 16:13 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 1.0.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The docks won't be allowed to be added to the existing station. This should be, since the whole docks fall within the station's build area.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Tuesday, 10 August 2010, 16:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r20438
Comment by frosch (frosch) - Tuesday, 10 August 2010, 06:21 GMT
  • Field changed: Status (New → Waiting on savegame)
Works for me.

Please attach a savegame. (if it is another game, then please also mark the tile to build the dock on)
Comment by energetic2 (energetic2) - Tuesday, 10 August 2010, 08:53 GMT
Make sure to have the exact station layout as used in the screenshot. It works in some angles, but the angle I showed will not work. "Not working" meaning the station name list will not show Prunley Market West.

I tried to reproduce myself, but I failed in a new game. So here is the savegame.
(application/octet-stream)    bug.sav (869 KiB)
Comment by Daniel (chillcore) - Tuesday, 10 August 2010, 14:07 GMT
Strangely enough it works if you first put an extra station tile next to where energetic2 tried to build the dock.
The dock refuses to join the existing station when using the CTRL feature and not having build the extra station tile first.
The dock falls within the max station spread setting of seven tiles but the opened window only shows the option to build a seperate station. (@see picture posted above)
Attached picture tested with OpenTTD r20383.

Loading...