OpenTTD

Tasklist

FS#4017 - Farms above snowline in sub-arctic, no forests with NEWGRF "station name from nearby industry v1.23"

Attached to Project: OpenTTD
Opened by Radium Mercury (Radium) - Sunday, 08 August 2010, 18:16 GMT
Last edited by frosch (frosch) - Sunday, 08 August 2010, 21:36 GMT
Type Bug
Category NewGRF
Status Closed
Assigned To No-one
Operating System Windows
Severity Medium
Priority Normal
Reported Version 1.0.3
Due in Version 1.0.4
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

== WARNING: Might be related to:  FS#4002  - Crash when starting new sub-arctic game with ECS. Town vector beta 5 ==

Bug has been introduced in OpenTTD 1.0.3 (wasn't in 1.0.2)

When creating new map, farms are above snowline and no forests at the start. When the game resumes it looks like the forests spawn again above the snowline and the farms only under the snowline.

Since no newgrf code changed the past 2-3 months, I conclude it must be OpenTTD
This task depends upon

Closed by  frosch (frosch)
Sunday, 08 August 2010, 21:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r20418
Comment by frosch (frosch) - Sunday, 08 August 2010, 19:23 GMT
  • Field changed: Status (New → Confirmed)
  • Field changed: Due in Version (Undecided → 1.0.4)
What actually happens:
During map generation industries are created before the tileloop runs. And snow appears first during the tileloop.

Since 1.0.3 newgrfs check for snow using the groundtypes stored in the maparray (which are set during the tileloop) and no longer using the snowline-height variable (set from the start).

Loading...