OpenTTD

Tasklist

FS#3960 - If non-dedicated server fails to load savegame title screen is loaded on the client

Attached to Project: OpenTTD
Opened by Pereyaslov Konstantin (perk11) - Sunday, 18 July 2010, 17:35 GMT
Last edited by Remko Bijker (Rubidium) - Sunday, 15 August 2010, 11:58 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version 1.0.4
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

 FS#3907  was fixed in r20039 and then I discovered that this issue is applicable to non-dedicated server too.
* Start a non-dedicated server
* Type "load <savegame that can't be loaded>" in the game console where the server is running
* Connect to the server

You'll find that the client is running the title game playable. However you can't do much since it will desync very soon.
(and you can't play on sever since it shows the main menu)
This task depends upon

Closed by  Remko Bijker (Rubidium)
Sunday, 15 August 2010, 11:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r20497
Comment by Pereyaslov Konstantin (perk11) - Sunday, 18 July 2010, 17:39 GMT
For a non-dedicated server clients dropping instead of generating a new map could fix it, because rcon is not needed.
Comment by Remko Bijker (Rubidium) - Tuesday, 20 July 2010, 16:59 GMT
  • Field changed: Status (New → Confirmed)
  • Field changed: Due in Version (Undecided → 1.0.4)
It's in my opinion not that important/significant that it warrants (possibly) delaying 1.0.3.

Loading...