OpenTTD

Tasklist

FS#3927 - Landscaping tool doesn't work

Attached to Project: OpenTTD
Opened by Dominic Spilka (Tepo99) - Monday, 05 July 2010, 09:47 GMT
Last edited by Remko Bijker (Rubidium) - Monday, 05 July 2010, 10:23 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity High
Priority Normal
Reported Version 1.0.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When i (and other people) try to use landscaping tool, it says:
"Can't level land here...
...already flat"
even if that land isn't flat.
Landscaping tool doesn't work with any newGRF and without any newGRF.
OS: Windows 7 Ultimate
Game version: 1.0.2

I haven't attached save because it doesn't work anywhere.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Monday, 05 July 2010, 10:23 GMT
Reason for closing:  Unsupported custom version
Comment by Remko Bijker (Rubidium) - Monday, 05 July 2010, 09:53 GMT
Sounds like you're using the level land tool instead of the raise/lower land tool. The raise/lower tools work on single corners of tiles, the level land tool needs at least a full tile selected for it to become useful. It doesn't work on one tile corner because it then doesn't know which tile to level as you would mean four tiles. Furthermore the level land tool won't level land that is already leveled.

Finally: the levelling tools seems to work just fine for me in 1.0.2.
Comment by Dominic Spilka (Tepo99) - Monday, 05 July 2010, 09:55 GMT
I mean if you drag for example 10x10 tile over a small hill, it writes that error. I know, landscaping tool doesn't work on single corner tile.
Comment by Remko Bijker (Rubidium) - Monday, 05 July 2010, 09:58 GMT
I just tested it and that works just fine for me. Do you have a savegame that I can use to reproduce it?
Comment by Dominic Spilka (Tepo99) - Monday, 05 July 2010, 10:03 GMT
So, i am sorry, i've just tried to record a vid. which shows, it doesnt work, but it work in single player. Then i tested it in multiplayer, and it doesn't work. Let's see here: http://www.youtube.com/watch?v=hrAczhmeW-U . Tested on OpenttdCOOP stable server.
Comment by Remko Bijker (Rubidium) - Monday, 05 July 2010, 10:13 GMT
Given the lack of trees in your screenshot and the fact that there are trees on the map it's very well conceivable that there was some structure that was hidden by the transparency settings which did not allow the ground to be changed.
Comment by Remko Bijker (Rubidium) - Monday, 05 July 2010, 10:23 GMT
Some more research has shown that the server is running a patch which effectively disables land levelling and limits raising/lowering land to one tile at a tile. The patch silently changes your level command to level a single corner, which is always considered level; as I said before you need a full tile.

As such... it's not a bug in OpenTTD but a bug caused by a patched version of OpenTTD (running at the server side).

Loading...