OpenTTD

Tasklist

FS#3892 - crash when clicking one of the vehicle listing buttons

Attached to Project: OpenTTD
Opened by Tobi Vollebregt (Tobi) - Monday, 21 June 2010, 19:02 GMT
Last edited by Remko Bijker (Rubidium) - Thursday, 08 July 2010, 08:51 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity High
Priority Normal
Reported Version 1.0.2
Due in Version 1.0.3
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When playing a game on one of the Luukland servers I could reproducably crash (segfault) openttd by clicking on one of the vehicle list buttons, i.e. the train/bug/boat/airplane button in the menu.

I've been unable to reproduce it with crash.sav, unfortunately.

Maybe the attached log/screenshot/etc. will still be useful.

I was using OpenTTD 1.0.2 (Note: this isn't in the dropdown yet.) on 32 bit Linux (Fedora 12). To be precise, I used the Linux Generic binary package that can be downloaded from the openttd site.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Thursday, 08 July 2010, 08:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r20041
Comment by Tobi Vollebregt (Tobi) - Monday, 21 June 2010, 19:06 GMT
Oh btw I was a spectator, in case that matters.
Comment by Troels Kofoed Jacobsen (tkjacobsen) - Tuesday, 22 June 2010, 11:55 GMT
I can reproduce this exact problem (being spectator, opening RV dialog) on Fedora 13, 64 bit, using generic linux binary.
Comment by Zdeněk Sojka (SmatZ) - Tuesday, 22 June 2010, 12:35 GMT
  • Field changed: Status (New → Confirmed)
  • Field changed: Operating System (Linux → All)
On trunk since r19955.

Loading...