OpenTTD

Tasklist

FS#3744 - Crash while navigating in city list

Attached to Project: OpenTTD
Opened by Fritz (fritzb) - Wednesday, 07 April 2010, 21:11 GMT
Last edited by Remko Bijker (Rubidium) - Thursday, 08 April 2010, 15:29 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 1.0.0
Due in Version 1.0.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The game crashed when I opened the city-list and tried to press "h" to jump to "Hedtown". Actually it didn't worked. I'm unable to reproduce the crash. My last savegame before the crash is a one y/o autosave, sorry.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Thursday, 08 April 2010, 15:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r19584
Comment by Thijs Marinussen (Yexo) - Wednesday, 07 April 2010, 22:43 GMT
Callstack from crash.dmp:

> openttd.exe!Window::SetWidgetDirty(unsigned char widget_index=0) Line 233 + 0x9 bytes C++
openttd.exe!OrdersWindow::OrderClick_Nonstop(int non_stop=-1) Line 635 C++
openttd.exe!OrdersWindow::OnKeyPress(unsigned short key=104, unsigned short keycode=72) Line 1210 C++
openttd.exe!HandleKeypress(unsigned int raw_key=0) Line 1921 + 0x9 bytes C++
openttd.exe!WndProcGdi(HWND__ * hwnd=0x00050374, unsigned int msg=258, unsigned int wParam=104, long lParam=2293761) Line 498 C++
user32.dll!_InternalCallWinProc@20() + 0x23 bytes
user32.dll!_UserCallWinProcCheckWow@32() + 0xb3 bytes
user32.dll!_DispatchMessageWorker@8() + 0x19e bytes
user32.dll!_DispatchMessageW@4() + 0xf bytes
openttd.exe!VideoDriver_Win32::MainLoop() Line 847 + 0xb bytes C++
openttd.exe!ttd_main(int argc=, char * * argv=) Line 761 C++
openttd.exe!WinMain(HINSTANCE__ * hInstance=0x00400000, HINSTANCE__ * hPrevInstance=0x00000000, char * lpCmdLine=0x002220af, int nCmdShow=1) Line 429 + 0x9 bytes C++
openttd.exe!__tmainCRTStartup() Line 263 + 0x1b bytes C
kernel32.dll!@BaseThreadInitThunk@12() + 0x12 bytes
ntdll.dll!___RtlUserThreadStart@8() + 0x27 bytes
ntdll.dll!__RtlUserThreadStart@8() + 0x1b bytes
Comment by Remko Bijker (Rubidium) - Thursday, 08 April 2010, 09:31 GMT
  • Field changed: Status (New → Confirmed)
  • Field changed: Due in Version (Undecided → 1.0.1)
It's not the city list that's the cause, it's the order window that causes the crash.

Loading...