OpenTTD

Tasklist

FS#3728 - Can build rainforest trees in desert and cacti in rainforest

Attached to Project: OpenTTD
Opened by Vít Šefl (Vitus) - Thursday, 01 April 2010, 22:35 GMT
Last edited by Remko Bijker (Rubidium) - Friday, 16 April 2010, 21:46 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version trunk
Due in Version 1.0.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello,

the behaviour of Lumber Mill (LM) placement is very strange.
Tested with r19532; O/S: Windows Vista

Everything's OK if you try to build LM in rainforest created in scenario editor (or in randomly generated map).
However, if you demolish such rainforest, the game still allows you to build LM in that area.

On the other side, the game doesn't allow you to build LM in newly created rainforest (i.e. the one created during actual gameplay).
It seems, that this kind of data is set in stone during map generation or scenario saving.

I'm attaching savegame, which should document this pretty well.

I'm not sure, if this is (or should be) intended behaviour.

Thanks for your time,
Vitus.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Friday, 16 April 2010, 21:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r19644
Comment by Vít Šefl (Vitus) - Friday, 02 April 2010, 21:41 GMT
Some additional info:

I found out, that only way to get rid of "rainforest" status, is either by using the desert tool or the un-desert tool. Demolishing, flooding and other kins of terraforming seem to have no effect on this.
Comment by Remko Bijker (Rubidium) - Thursday, 08 April 2010, 09:37 GMT
Yes, the rain forest/desert state is something that is set during map creation / in the scenario editor. You can't change that in-game.

You can see which "type" piece of ground is in by building random trees; the desert will get cacti, the rainforest will get rainforest trees and the rest gets the remaining trees.

The rain forest is special as trees spawn much quicker than on any other ground. As the lumber mill chops the trees, you need to faster spawning trees.

So the thing that I'd change is the ability to build rainforest trees in non-rainforest areas to prevent people from thinking they then can build a lumber mill there (and building of cacti in the rainforest areas).

Loading...