OpenTTD

Tasklist

FS#3702 - Crash after ignoring 'NewGRFs changed' warning

Attached to Project: OpenTTD
Opened by Dan Chaplin (oddy) - Thursday, 18 March 2010, 11:18 GMT
Last edited by Thijs Marinussen (Yexo) - Tuesday, 24 August 2010, 16:00 GMT
Type Bug
Category NewGRF
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Normal
Reported Version 1.0.0-RC3
Due in Version 1.1.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Crashes during game, if reloaded will continue to crash at the same point every time, this seems to happen even with no user interaction.

*** OpenTTD Crash Report ***

Crash at: Thu Mar 18 11:08:50 2010
In game date: 2056-07-16 (35)

Crash reason:
Exception: E1212012
Location: 758F9617
Message: Assertion failed at line 2208 of ..\src\town_cmd.cpp: IsTileType(tile, MP_HOUSE)

OpenTTD version:
Version: 1.0.0-RC3 (0)
NewGRF ver: 10004bf7
Bits: 32
Endian: little
Dedicated: no
Build date: Mar 17 2010 23:37:08

Registers:
EAX: 0012F568 EBX: 00000016 ECX: 00000000 EDX: 776164F4
ESI: 007781E8 EDI: 00000000 EBP: 0012F5B8 ESP: 0012F568
EIP: 758F9617 EFLAGS: 00200246

Bytes at instruction pointer:
C9 C2 10 00 89 45 C0 EB ED 90 90 90 90 90 8B FF 55 8B EC 83 EC 1C 6A 00

Stack trace:
E1212012 00000000 00000000 758F9617 00000000 75A862E3 AD48B0A9 FFFFFFFE
75A3888D 009C0000 00000040 00A32A30 7761549C 77633263 FFFFFFFF 00000024
0012F5B4 00000004 00000000 00000016 0012F618 0054EB02 E1212012 00000000
00000000 00000000 0061D9C2 00000016 D8F7040B 0012F960 00000200 000EEC6A
7762F037 FFFFFFFF 00000000 0012F600 0054EAF2 00000001 0012F5D8 0012F16C
0012FBE4 006226B0 D891EC7B FFFFFFFE 0012F950 0061CD4B 00000016 00000200
00A374A8 00B93860 00000082 00000000 009C2AE8 00000000 009C2AB8 75A552B9
00030CBA 00A32A38 00A32FF8 00000001 00000026 00000000 01000000 00000000
00000130 010103F7 0012F5A8 00000000 0012FBE4 775ED74D 0066BDE7 FFFFFFFE
7762316F 77622D68 00000000 00A32A38 00000000 00010003 0012F89C 00A32A30
0012F740 75A7E16D 009C0000 00000000 00A32A38 00000001 0012F89C 00000001
00000000 00000000 00000690 000003F2 00000000 007CBBD8 00000010 0000001C
0000000F 00030CBA 00000006 000004C0 00000000 00000351 00000000 00000163
00000001 50022080 00290D48 00000000 00000000 00000035 00007F01 00A32A38
00000001 0000001E 00000000 00000020 000001D0 00A32A9C 0012F890 75A7E6B9
00000010 0012F960 00000200 75A7E6F1 00000001 0012F818 0012F854 00030CBA
00290784 00010000 00020001 000000A0 00000000 00000000 75A7E70C 00000000
00000001 00000000 00000004 00000003 00000000 00000000 00000008 00000004
00000006 00000000 00000000 00000000 00000000 00000000 00000001 00000016
00000000 00000000 0000001C 00000011 0000000D 0000000D 6B10230D 01850465
9A102365 00000000 00000017 0000000C 00940808 00000000 00000000 00000000
00000000 00000000 000001F9 00000000 000003C0 000001F9 0012F838 7402657E
00000000 74021E45 00030CBA 00000084 00000000 01F903C0 0012F888 00000000
00000000 00000084 00000000 00030CBA 00000084 0000007F 0012F960 007CBBD8

Operating system:
Name: Windows
Release: 6.1.7600 ()
Compiler: MSVC 1500

Configuration:
Blitter: 8bpp-optimized
Graphics set: OpenGFX
Language: english.lng
Music driver: dmusic
Music set: NoMusic
Network: no
Sound driver: win32
Sound set: NoSound
Video driver: win32

AI Configuration (local: 0):
0: Human

Libraries:
FreeType: 2.3.12
ICU: 4.2.1
LZO: 2.03
PNG: 1.2.43
Zlib: 1.2.3

Module information:
C:\Program Files\OpenTTD\openttd.exe handle: 00400000 size: 3670016 crc: 90FC6823 date: 2010-03-17 23:40:26
C:\Windows\SYSTEM32\ntdll.dll handle: 775D0000 size: 1286144 crc: D1A0A49D date: 2009-07-14 01:17:51
C:\Windows\system32\kernel32.dll handle: 75B70000 size: 857088 crc: 1DC306D9 date: 2009-12-08 11:33:31
C:\Windows\system32\KERNELBASE.dll handle: 758F0000 size: 288256 crc: 37432389 date: 2009-07-14 01:15:35
C:\Windows\system32\WINMM.dll handle: 73CC0000 size: 194048 crc: 2FBEB05C date: 2009-07-14 01:16:19
C:\Windows\system32\msvcrt.dll handle: 76E40000 size: 690688 crc: 554C94A4 date: 2009-07-14 01:15:50
C:\Windows\system32\USER32.dll handle: 75A20000 size: 811520 crc: F5A646DD date: 2009-07-14 01:16:17
C:\Windows\system32\GDI32.dll handle: 77710000 size: 304640 crc: 252D0177 date: 2009-07-14 01:15:22
C:\Windows\system32\LPK.dll handle: 777F0000 size: 26624 crc: 13E68B63 date: 2009-07-14 01:15:36
C:\Windows\system32\USP10.dll handle: 760F0000 size: 627200 crc: 3887C4C8 date: 2009-07-14 01:16:17
C:\Windows\system32\WS2_32.dll handle: 77230000 size: 206336 crc: 4C23BF22 date: 2009-07-14 01:16:20
C:\Windows\system32\RPCRT4.dll handle: 76F80000 size: 652288 crc: 14458268 date: 2009-07-14 01:16:13
C:\Windows\system32\NSI.dll handle: 75F50000 size: 8704 crc: 2ACE9671 date: 2009-07-14 01:16:11
C:\Windows\system32\ADVAPI32.dll handle: 77030000 size: 640000 crc: 24248FE4 date: 2009-07-14 01:14:53
C:\Windows\SYSTEM32\sechost.dll handle: 760D0000 size: 92160 crc: B624B29A date: 2009-07-14 01:16:13
C:\Windows\system32\SHELL32.dll handle: 761F0000 size: 12866560 crc: 1FCAA9C5 date: 2009-07-14 01:16:14
C:\Windows\system32\SHLWAPI.dll handle: 76190000 size: 350208 crc: 8D9B2C39 date: 2009-07-14 01:16:14
C:\Windows\system32\IMM32.DLL handle: 77210000 size: 118272 crc: F2F44531 date: 2009-07-14 01:15:32
C:\Windows\system32\MSCTF.dll handle: 76000000 size: 828928 crc: DFE09EEB date: 2009-07-14 01:15:43
C:\Windows\system32\SHFolder.dll handle: 72020000 size: 7168 crc: 683AAC32 date: 2009-07-14 01:16:14
C:\Windows\system32\ole32.dll handle: 77270000 size: 1412608 crc: 4ACC7A3A date: 2009-07-14 01:16:12
C:\Windows\system32\MMDevAPI.DLL handle: 749E0000 size: 213504 crc: 352DF99F date: 2009-07-14 01:15:41
C:\Windows\system32\PROPSYS.dll handle: 748E0000 size: 988160 crc: 0700E8D7 date: 2009-07-14 01:16:12
C:\Windows\system32\OLEAUT32.dll handle: 75F70000 size: 571904 crc: DCE3E850 date: 2009-07-14 01:16:12
C:\Windows\system32\wdmaud.drv handle: 73C90000 size: 172032 crc: 03BEEBE2 date: 2009-07-14 01:14:08
C:\Windows\system32\ksuser.dll handle: 73C80000 size: 4608 crc: EBE07232 date: 2009-07-14 01:15:35
C:\Windows\system32\AVRT.dll handle: 748D0000 size: 14336 crc: 9818237B date: 2009-07-14 01:14:58
C:\Windows\system32\SETUPAPI.dll handle: 75C50000 size: 1668608 crc: F909EF01 date: 2009-07-14 01:16:14
C:\Windows\system32\CFGMGR32.dll handle: 758C0000 size: 145920 crc: 6377C630 date: 2009-07-14 01:15:02
C:\Windows\system32\DEVOBJ.dll handle: 759D0000 size: 64512 crc: 2B501D62 date: 2009-07-14 01:15:11
C:\Windows\system32\AUDIOSES.DLL handle: 73870000 size: 195584 crc: BC939745 date: 2009-07-14 01:14:57
C:\Windows\system32\msacm32.drv handle: 73860000 size: 20992 crc: 73923147 date: 2009-07-14 01:14:08
C:\Windows\system32\MSACM32.dll handle: 73840000 size: 72192 crc: ABA25814 date: 2009-07-14 01:15:42
C:\Windows\system32\midimap.dll handle: 73830000 size: 16896 crc: C000494C date: 2009-07-14 01:15:40
C:\Windows\system32\CRYPTBASE.dll handle: 756A0000 size: 36864 crc: 00308E17 date: 2009-07-14 01:15:07
C:\Windows\system32\CLBCatQ.DLL handle: 76EF0000 size: 522240 crc: 6C130B8A date: 2009-07-14 01:15:03
C:\Windows\system32\uxtheme.dll handle: 74020000 size: 249856 crc: 1CD7BB78 date: 2009-07-14 01:16:17
C:\Windows\system32\PGPhk.dll handle: 10000000 size: 50744 crc: D8CAE2CB date: 2008-08-22 18:48:58
C:\Windows\system32\dwmapi.dll handle: 73D30000 size: 67072 crc: FC7CA4B8 date: 2009-07-14 01:15:13
C:\Windows\System32\dmime.dll handle: 6C980000 size: 179712 crc: 179D7CFB date: 2009-07-14 01:15:12
C:\Windows\System32\DSOUND.dll handle: 6B010000 size: 453632 crc: EC24F2F8 date: 2009-07-14 01:15:13
C:\Windows\System32\POWRPROF.dll handle: 74A20000 size: 145408 crc: 9957ABF4 date: 2009-07-14 01:16:12
C:\Windows\System32\dmusic.dll handle: 6D590000 size: 101376 crc: F5D0AA6B date: 2009-07-14 01:15:12
C:\Windows\system32\WINTRUST.dll handle: 759F0000 size: 172544 crc: 3753F315 date: 2009-07-14 01:16:19
C:\Windows\system32\CRYPT32.dll handle: 757A0000 size: 1151488 crc: CC34327C date: 2009-07-14 01:15:07
C:\Windows\system32\MSASN1.dll handle: 75790000 size: 34816 crc: 4F65C9C8 date: 2009-08-29 06:57:31
C:\Windows\System32\dmsynth.dll handle: 71FF0000 size: 105472 crc: 3B102040 date: 2009-07-14 01:15:12
C:\Windows\System32\dmloader.dll handle: 6D600000 size: 38400 crc: 8A3F45D2 date: 2009-07-14 01:15:12
C:\Windows\system32\mswsock.dll handle: 75190000 size: 232448 crc: 32400D27 date: 2009-07-14 01:15:51
C:\Windows\System32\wshtcpip.dll handle: 74C60000 size: 9216 crc: BA963A19 date: 2009-07-14 01:16:20
C:\Windows\system32\psapi.dll handle: 75F60000 size: 6144 crc: 25B988F9 date: 2009-07-14 01:16:12

---- gamelog start ----
Tick 0: new game started
Revision text changed to r16889, savegame version 122, not modified, _openttd_newgrf_version = 0x080041f9
New game mode: 2 landscape: 0
Added NewGRF: GRF ID 50430301, checksum 019EC35F3327E5069E68A8AD990C1AAE, filename: british_town_names-2.1\brit_names.grf
Added NewGRF: GRF ID 6D620601, checksum E5BB55CF0C0FCAFCBC4A402BF5E870BF
Added NewGRF: GRF ID 56430001, checksum 6B3CAAEE94A08F444D9F3429CEA2CB2A
Added NewGRF: GRF ID 74677462, checksum A2396FFDCC0F1BA37A2A89EF525CDF21
Added NewGRF: GRF ID 46420801, checksum 2D654630F22AA4C78A58710024C514B3, filename: new_tram_tracks.0.4.1\newtramtracksw_v0.4.1.grf
Added NewGRF: GRF ID 4A430002, checksum 0728ADCB4DF2F1EB9247ABD449296F4E
Added NewGRF: GRF ID 44440A01, checksum A7EA6FB6732157AEE44627A64EBCDAE6
Added NewGRF: GRF ID 6D620004, checksum 70649F1AFC954942173B0AA89C1E8B14
Added NewGRF: GRF ID 4D470901, checksum 887847A49FDA37D8C7F61297C26A40F0
Added NewGRF: GRF ID 44440201, checksum DBEE7FED4B51E27E53FB7A14E283BE38
Added NewGRF: GRF ID 43520001, checksum 93FB56B6B628FFE0FD8A098A01C3E786
Added NewGRF: GRF ID 27711002, checksum 3E2A2578101FFB3DD8AFC451CC43C8D0
Added NewGRF: GRF ID 535A1344, checksum EE64CDD6E4600C717B448583026DF24D
Added NewGRF: GRF ID 52571201, checksum C1C7D8C53EB7E74EEE2F0EF29638B466
Added NewGRF: GRF ID FBFB9905, checksum F747797A14AAA646402DC4E16DE5E82C
Added NewGRF: GRF ID FBFB0401, checksum E497AFEB67D7501658FFC709C2E474A9, filename: metro_track_set.0.2.2\metrotracksetw.grf
Tick 0: GRF config changed
Removed NewGRF: 27711002
Removed NewGRF: 535A1344
Added NewGRF: GRF ID 19060801, checksum 6CFC6328D999C140851BFE6514BA277A
Added NewGRF: GRF ID 45520400, checksum 1D00426064137AA49B6FC4F4BCFF173F
Added NewGRF: GRF ID 52455400, checksum 1600687C50C5AB1E72EDD487CAD50E2A
Added NewGRF: GRF ID 45520500, checksum 7E30CA79D5A8B3A6CBE873E26096D7D2
Added NewGRF: GRF ID 45520600, checksum 346457CB4632554B6A175785236883E4
Added NewGRF: GRF ID 52455200, checksum 0E5A9C5ACD2BCAF7FA0658C3F905A660
Added NewGRF: GRF ID 52455300, checksum 37C0B839B13C4B18051580C81EEDF427
Added NewGRF: GRF ID 44440111, checksum 9B5051E70D60EF2926A249B923AFB0CA, filename: uk_renewal_set.3.04\pb_ukrs.grf
Added NewGRF: GRF ID 44442202, checksum 3DAC7433C0DA14AD3C5E8C89D73A6A2E, filename: uk_renewal_set_addon_pack.3.04\ukrsap1w.grf
Removed NewGRF: FBFB0401, filename: metro_track_set.0.2.2\metrotracksetw.grf
Tick 0: game loaded
Revision text changed to 1.0.0-beta4, savegame version 138, not modified, _openttd_newgrf_version = 0x10004a40
Removed NewGRF: 50430301, filename: british_town_names-2.1\brit_names.grf
Compatible NewGRF loaded: GRF ID 6D620601, checksum 44EB2F155862E4D4F0AB671D7021AF54
Compatible NewGRF loaded: GRF ID 56430001, checksum AF3E0A1E6EF0B98DB966594578D1775B
Removed NewGRF: 46420801, filename: new_tram_tracks.0.4.1\newtramtracksw_v0.4.1.grf
Compatible NewGRF loaded: GRF ID 4D470901, checksum 7A0FB842DAA8A2F7A57857C01C4939FD
Removed NewGRF: 44440201
Removed NewGRF: 43520001
Removed NewGRF: 19060801
Removed NewGRF: 45520600
Tick 0: GRF config changed
Removed NewGRF: 6D620601
Removed NewGRF: 74677462
Removed NewGRF: 4A430002
Removed NewGRF: 44440A01
Removed NewGRF: 6D620004
Removed NewGRF: 4D470901
Removed NewGRF: 52571201
Removed NewGRF: FBFB9905
Removed NewGRF: 45520400
Removed NewGRF: 52455400
Removed NewGRF: 45520500
Removed NewGRF: 52455200
Removed NewGRF: 52455300
Removed NewGRF: 44440111, filename: uk_renewal_set.3.04\pb_ukrs.grf
Removed NewGRF: 44442202, filename: uk_renewal_set_addon_pack.3.04\ukrsap1w.grf
Tick 0: game loaded
Revision text changed to 1.0.0-RC2, savegame version 138, not modified, _openttd_newgrf_version = 0x10004b71
Removed NewGRF: 56430001
Tick 0: GRF config changed
Added NewGRF: GRF ID 4D570102, checksum 8C41066F2430A1762047AB077B51EE63, filename: hover_bus.1.0\hoverbus_1.0.grf
Added NewGRF: GRF ID 50430301, checksum 019EC35F3327E5069E68A8AD990C1AAE, filename: british_town_names-2.1\brit_names.grf
Added NewGRF: GRF ID 554B5201, checksum 0D9C15FF1DC9AA50702780A730D9C650, filename: uk_roadset.1.1\ukroadsetw.grf
Added NewGRF: GRF ID 46420801, checksum 2D654630F22AA4C78A58710024C514B3, filename: new_tram_tracks.0.4.1\newtramtracksw_v0.4.1.grf
Added NewGRF: GRF ID 52570103, checksum EDB2D26F9D81423734CA12412F309CF3, filename: generic_tram_set.0.4\generictrams.grf
Tick 0: game loaded
New game mode: 1 landscape: 0
Tick 65489: game loaded
Revision text changed to 1.0.0-RC3, savegame version 138, not modified, _openttd_newgrf_version = 0x10004bf7
---- gamelog end ----

*** End of OpenTTD Crash Report ***
(application/octet-stream)    crash.dmp (945.3 KiB)
   crash.log (12.9 KiB)
   crash.png (156.1 KiB)
(application/octet-stream)    crash.sav (4.98 MiB)
This task depends upon

Closed by  Thijs Marinussen (Yexo)
Tuesday, 24 August 2010, 16:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r20609.
Comment by Thijs Marinussen (Yexo) - Thursday, 18 March 2010, 14:57 GMT
  • Field changed: Status (New → Confirmed)
  • Field changed: Category (Core → NewGRF)
  • Field changed: Due in Version (Undecided → 1.1.0)
  • Field changed: Operating System (Windows → All)
  • Field changed: Severity (Medium → Very Low)
It crashes because you started the game with a house newgrf that is no longer available. The big red warning you get when you change newgrfs is there for a reason.
Comment by Loïc GUILLOUX (glx) - Sunday, 22 August 2010, 22:38 GMT
> KERNELBASE.dll!_RaiseException@16() + 0x54 octets
openttd.exe!CustomAbort(int signal) Ligne 417 C++
openttd.exe!raise(int signum) Ligne 590 + 0x4 octets C
openttd.exe!abort() Ligne 71 + 0x7 octets C
openttd.exe!error(const char * s, ...) Ligne 131 C++
openttd.exe!DoClearTownHouseHelper(unsigned int tile, Town * t, unsigned short house) Ligne 2209 C++
openttd.exe!ClearTownHouse(Town * t, unsigned int tile) Ligne 2271 C++
openttd.exe!TileLoop_Town(unsigned int tile) Ligne 528 C++
openttd.exe!RunTileLoop() Ligne 674 C++
openttd.exe!StateGameLoop() Ligne 1217 C++
openttd.exe!GameLoop() Ligne 1303 C++
openttd.exe!VideoDriver_Win32::MainLoop() Ligne 889 C++
openttd.exe!ttd_main(int argc, char * * argv) Ligne 761 C++
openttd.exe!WinMain(HINSTANCE__ * hInstance, HINSTANCE__ * hPrevInstance, char * lpCmdLine, int nCmdShow) Ligne 429 + 0x9 octets C++
openttd.exe!__tmainCRTStartup() Ligne 263 + 0x1b octets C
kernel32.dll!@BaseThreadInitThunk@12() + 0x12 octets
ntdll.dll!___RtlUserThreadStart@8() + 0x27 octets
ntdll.dll!__RtlUserThreadStart@8() + 0x1b octets

Loading...