OpenTTD

Tasklist

FS#3651 - [OSX] Game crashes when full screen is selected

Attached to Project: OpenTTD
Opened by Emin (niw3) - Sunday, 28 February 2010, 10:08 GMT
Last edited by Ingo von Borstel (planetmaker) - Tuesday, 07 December 2010, 22:05 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Mac OS X
Severity High
Priority Normal
Reported Version 1.0.0-RC1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I click the full screen button the screen goes black for a while and then game crashes. It doesn't matter if I try this in game or at the menu (title game).

OS X version : 10.5.8
This task depends upon

This task blocks these from closing
 FS#2782 - [OSX] Port hopelessly outdated 
Closed by  Ingo von Borstel (planetmaker)
Tuesday, 07 December 2010, 22:05 GMT
Reason for closing:  Unreproducible
Additional comments about closing:  Not even the original author can reproduce it. Nor did I manage to reproduce it with the help of a 2nd screen.
Comment by Remko Bijker (Rubidium) - Sunday, 28 February 2010, 10:21 GMT
  • Field changed: Summary (Game crashes when full screen is selected → [OSX] Game crashes when full screen is selected)
  • Field changed: Status (New → Not confirmed)
I hope you are aware that Mac OS X is not officially supported anymore and that we don't have a Mac OS X maintainer and as such the chances of this bug getting fixed in a timely matter are really small.
Comment by Patrick (Chakotay) - Tuesday, 02 March 2010, 15:58 GMT
Hi Emin

Does it always happen when you try full screen? Have you tried one of the nightly builds?

At least on Mac OS X 10.6.2 I could not reproduce your error, using your save game.
It could be because of the different OS, of course.
Comment by Emin (niw3) - Saturday, 27 March 2010, 15:32 GMT
Hi Patrick,

I tried 1.0.0-RC2, RC3, and r19519. Still the same.
Comment by Emin (niw3) - Saturday, 27 March 2010, 16:11 GMT
If it helps, exactly the following happens:

When I click full screen, openttd window disappears, system mouse cursor appears, screen fades out to black, screen fades in to white with system cursor visible. Then screen makes another fade out/fade in. After that only system cursor is visible. No dock or background. Not even spaces or expose works. I have to forcefully quit the openttd executable to return to my desktop.
Comment by Patrick (Chakotay) - Tuesday, 13 April 2010, 08:04 GMT
Guess someone with a 10.5 version of the OS needs to try this out.
With my Snow Leopard (10.6), it seems to work fine. Checked it again today - works for me.

Anyone else here with Mac OS 10.5 ?
Comment by Mathew Eis (matheweis) - Sunday, 02 May 2010, 04:04 GMT
I also am not able to reproduce this with either 1.0.1 or r19750 under 10.6.3.

If you are still able to reproduce this, please go to http://support.apple.com/kb/HT1582. When you get to the screen shown, copy and paste all the information given under the Graphics/Displays section.
Comment by Arjan Franzen (TheFranz) - Saturday, 08 May 2010, 21:08 GMT
Hi there,

I use Mac OS 10.5 and am not able to reproduce the crash either. (using the savegame)

I have however a question on the resulution you're selecting, 1920x1080: I don't have that resolution.
my max resolution is 1920x1200. 1920x1080 is not available on my machine.
any ideas how that is possible?

Comment by Mathew Eis (matheweis) - Saturday, 08 May 2010, 21:16 GMT
It's very possible. 1920x1080 is 1080p HDTV resolution, he probably had it hooked up to a big screen TV.
Comment by Chris Allan (callan) - Tuesday, 18 May 2010, 20:13 GMT
I managed to reproduce this once, on the main menu before loading the game. Haven't been able to since. 1440x900, built-in MacBook Pro 15" display. Mac OS X 10.6.3. 2.66GHz Intel Core i7.

$ git rev-parse HEAD
0449d7d5b92774d820cc4f93eca847f740c60385

$ git log -1
commit 0449d7d5b92774d820cc4f93eca847f740c60385
Author: smatz <smatz@openttd.org>
Date: Tue May 18 01:10:23 2010 +0000

(svn r19850) -Codechange: move declaration of InitializeRailGUI() to rail_gu...
Comment by urdh (urdh) - Saturday, 10 July 2010, 14:00 GMT
Cannot reproduce this in OSX 10.6.4 using r20110.
Comment by Kiike (Kiike) - Sunday, 15 August 2010, 18:30 GMT
I cannot either reproduce this bug, trying different resolutions and switching back and forth to fullscreen mode on SVN r20500, on a MacBook Pro 3,1 with OS X 10.6.4.
Comment by Emin (niw3) - Saturday, 21 August 2010, 15:29 GMT
Hi,

Yes you are right. I use an external display at 1920x1080. It is a common desktop LCD. I connect it to my mbpro 17 with a DVI-VGA cable. The reason I use an external LCD is that my internal LCD's backlight isn't working. I tried to reproduce the error on mbpro's built-in display with external display disconnected, which is presumably what you folks are doing, but I couldn't. It seems that the crash only happens when using an external display and mirroring on. Anyway, I've just tested 1.0.3, and it seems to be fixing this bug. Thanks to all involved.
Comment by Ingo von Borstel (planetmaker) - Tuesday, 16 November 2010, 08:26 GMT
there was to my knowledge no change in the related OpenTTD code between 1.0.0-RC1 and 1.0.3...

So doing the exact same thing (using a mirror display) on the same hardware and system setup does not trigger this anymore or something else (other computer (hardware), other OS version, ...) that changed on your setup between those two versions?

Loading...