OpenTTD

Tasklist

FS#345 - CONSTANT scrolling on laptop

Attached to Project: OpenTTD
Opened by Anonymous Submitter - Wednesday, 13 September 2006, 13:21 GMT
Type Bug
Category Interface
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 0.4.8
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When the game moves from the initial menu to the gameplay environment the display constantly scrolls downwards until the bottom of the map is reached. If you scroll/move to a different location it just repeats.
Running 0.4.8 under windows XP on an IBM thinkpad R40e laptop
This task depends upon

Closed by  Darkvater (Darkvater)
Thursday, 07 December 2006, 23:09 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Thank you SAM for posting the solution, I have updated the wiki here:
http://wiki.openttd.org/index.php/FAQ_tr oubleshooting#The_game_keeps_scrolling_o n_my_IBM_ThinkPad_Laptop
Comment by yorkshire_spam (yorkshire_spam) - Wednesday, 13 September 2006, 13:38 GMT
Sorry, I found a work around!
How to get Scrolling working with IBM Thinkpads

In the "Pass 0 rules" section of (either) %SYSTEM_ROOT%System32tp4table.dat or %SYSTEM_ROOT%System32tp4scrol.dat, add:

*,*,openttd.exe,*,*,*,WheelStd,0,9

(same fix as getting Opera to work on the thinkpad)

Loading...