OpenTTD

Tasklist

FS#3369 - Train is lost if auto-servicing is turned on while game is running for several years

Attached to Project: OpenTTD
Opened by Roland Haeder (Quix0r) - Monday, 14 December 2009, 01:18 GMT
Last edited by Thijs Marinussen (Yexo) - Monday, 04 January 2010, 21:19 GMT
Type Bug
Category Vehicles → YAPF
Status Closed
Assigned To No-one
Operating System Linux
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Unfortunately I have erased the savegame, so I need to describe it step-by step:

- First, switch off auto-servicing (e.g. auto-replace old trains) in advanced options
- Switch off failure of vehicles (they have no break downs)
- Start a new game (I choose normal (no temperated, sugar, winter)
- Play the game as usual and layout a centralized network of tracks. This means you have a 'big core' of 4 tracks and only adds smaller tracks to mines, factories, etc.. (I really need to play it again for you for better demonstration...)
- Now, let your trains become very, very old (double time)
- Switch on auto-servicing/auto-replacing of old vehicles.
- All, except trains, will be replaced safely. But some trains will get lost because they head for a depot far away from their regular track they choose to ride
- They will circle next to the depot and cannot head back. :(

My suggestion here would be that auto-servicing should only happen in depots which are on the regular tracks. Good examples (because the train will find back to the regular path) are the station's depots in the listed stations (which you need to add, anyway).
This task depends upon

Closed by  Thijs Marinussen (Yexo)
Monday, 04 January 2010, 21:19 GMT
Reason for closing:  Unreproducible
Additional comments about closing:  Feel free to open a new report if you can reliable reproduce it.
Comment by Roland Haeder (Quix0r) - Monday, 14 December 2009, 01:26 GMT
Please add revision: 18495
Comment by Remko Bijker (Rubidium) - Friday, 18 December 2009, 21:40 GMT
Could you make a savegame where we only need to load the savegame to show the problems?
Comment by Roland Haeder (Quix0r) - Friday, 18 December 2009, 22:24 GMT
The problem is, that this bug is not easy to reproduce. So I have attached my current savegame. When you load it, it won't happen because auto-servicing is turned ON.

What you have to do (besides praying that the bug will come again) is following:
- Load the game
- Turn off auto-servicing
- Speed up the time (2nd button in top bar)
- Let all become really old (5 to 10 years overdue should be fine)
- Reactivate auto-servicing and watch for lost-messages.

Hope, you can reproduce the bug. :)
Comment by Alberth (Alberth) - Saturday, 19 December 2009, 08:44 GMT
Rubidium asked you for a save game that reproduces the problem immediately, not for one where it might happen (we have an infinitely many of those).

I briefly looked at your save game, and there seem to exist (depot) routing problems in it. See the attached picture of a part of Tillyberg Bay East. When a train comes from the direction indicated by the arrow labeled '0' leaves the station, press 'send to depot'. After it stopped in the depot, start it again. There is no rail track to the direction it wants to go. As a result it takes a different route, and it reports a 'lost' message.
Comment by Roland Haeder (Quix0r) - Saturday, 19 December 2009, 09:28 GMT
Okay, fixed that. And where is the other screenshot part from? I have all electrified tracks.
Comment by Remko Bijker (Rubidium) - Saturday, 19 December 2009, 09:33 GMT
It's the same location, just with transparancy (50-ish% and 100%) turned on; you can see a blackish line of the catenary. You can also see that all vehicles are at the exact same place. Not showing the catenary as visible as usually makes it easier to see the actual track and possible defects with it.
Comment by Roland Haeder (Quix0r) - Saturday, 19 December 2009, 09:34 GMT
Damn. I always mean "autorenew", not auto-servicing... :( :( :(
Comment by Remko Bijker (Rubidium) - Saturday, 19 December 2009, 21:13 GMT
I've turned of autorenewing and let the game run in fast forward for 30 years. Then I've enables autorenewing and in 5 years not one vehicle was lost.
Comment by Roland Haeder (Quix0r) - Saturday, 19 December 2009, 21:23 GMT
Hmmm, I had a network that looks like a Q from far distance. Okay, I can try to construct such network, but with a different savegame. I don't want to mess my current one.
Comment by Remko Bijker (Rubidium) - Thursday, 31 December 2009, 09:33 GMT
Any succes with reproducing it?
Comment by Roland Haeder (Quix0r) - Thursday, 31 December 2009, 16:02 GMT
Currently, no luck. :( I will report back and (of course) save the game and upload it here.

Loading...