OpenTTD

Tasklist

FS#3344 - ECS cargo is unloaded but not paid for

Attached to Project: OpenTTD
Opened by Roman Onufryk (onufryk) - Wednesday, 02 December 2009, 22:29 GMT
Last edited by frosch (frosch) - Saturday, 12 December 2009, 23:59 GMT
Type Bug
Category NewGRF → NewIndustries
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version 0.7.4
Due in Version 0.7.5
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have a bug with a payment for a cargo delivery.
The bug raised after switching from the 0.7.4-RC1 to the 0.7.4 release

After some kinds of cargo delivered (e.g. sand to glass factory, refining to chemistry plant and so on), the cargo is unloaded, but no payment is processed, so train goes down into minus balance

In the build 18359 the bug is not reproducible.

Graphics used:
ecs_town_vector.b5__25_nov_2009_\ecstownw.grf = 0 0 0 15
ecs_basic_vector.b5__25_nov_2009_\ecsbasicw.grf = 0 15
ottdc_grfpack\5_industries_cargos\ECSHouse\ECSHousew.grf =
ecs_machinery_vector.b5__25_nov_2009_\ecsmachw.grf = 15
ecs_chemical_vector_ii.b5__25_nov_2009_\ecschem2w.grf = 15
north_american_renewal_set.2_03\nars2w.grf =
This task depends upon

Closed by  frosch (frosch)
Saturday, 12 December 2009, 23:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r18475 of 0.7 branch
Comment by Remko Bijker (Rubidium) - Wednesday, 02 December 2009, 22:43 GMT
Where is the savegame?

Furthermore I don't see difference between 0.7.4-RC1 and 0.7.4 that is not in 18359.
Comment by Roman Onufryk (onufryk) - Thursday, 03 December 2009, 07:07 GMT
Sorry, added savegame. Do you need graphic files?
Comment by Ingo von Borstel (planetmaker) - Thursday, 03 December 2009, 08:59 GMT
Works for me. The train receives income upon having finished unloading.
Comment by Remko Bijker (Rubidium) - Thursday, 03 December 2009, 09:37 GMT
For now 'reapplying' the NewGRF settings once you started a game is at least a work around for the problem.

Loading...