OpenTTD

Tasklist

FS#3298 - Fatal Application Failure when exit

Attached to Project: OpenTTD
Opened by Lasse (fenrer) - Tuesday, 03 November 2009, 20:11 GMT
Last edited by Remko Bijker (Rubidium) - Sunday, 06 December 2009, 20:22 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r16883
This task depends upon

Closed by  Remko Bijker (Rubidium)
Sunday, 06 December 2009, 20:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r18418
Comment by Loïc GUILLOUX (glx) - Tuesday, 03 November 2009, 21:40 GMT
> ntdll.dll!76f366ab()
[Les frames ci-dessous sont peut-être incorrects et/ou manquants, aucun symbole chargé pour ntdll.dll]
openttd.exe!free(void * pBlock=0x80000000) Ligne 110 C
openttd.exe!AIInfo::~AIInfo() Ligne 148 + 0xb octets C++
openttd.exe!AIInfo::`scalar deleting destructor'() + 0x9 octets C++
openttd.exe!SimpleCountedObject::Release() Ligne 29 C++
openttd.exe!SQConvert::DefSQDestructorCallback<AIAbstractList>(void * p=0x00000000, int size=0x00000000) Ligne 859 C++
openttd.exe!SQInstance::Release() Ligne 65535 C++
openttd.exe!SQObjectPtr::operator=(const tagSQObject & obj={...}) Ligne 321 C++
openttd.exe!AIScanner::~AIScanner() Ligne 82 + 0x41 octets C++
openttd.exe!AI::Uninitialize(bool keepConfig=false) Ligne 138 + 0x11 octets C++
openttd.exe!ShutdownGame() Ligne 333 C++
openttd.exe!ttd_main(int argc=0x00000001, char * * argv=0x0012fdf8) Ligne 753 C++
openttd.exe!WinMain(HINSTANCE__ * hInstance=0x00400000, HINSTANCE__ * hPrevInstance=0x00000000, char * lpCmdLine=0x001f1d47, int nCmdShow=0x00000001) Ligne 380 + 0x9 octets C++
openttd.exe!__tmainCRTStartup() Ligne 263 + 0x1b octets C
kernel32.dll!76b4d0e9()
Comment by Remko Bijker (Rubidium) - Wednesday, 04 November 2009, 00:15 GMT
Does this always happen when you quit? Even when quiting from the main menu?
Or is it only when loading a specific savegame?

What AIs/AI libraries do you have installed?
Comment by Lasse (fenrer) - Monday, 16 November 2009, 11:39 GMT
It always happens when i quit, also from the main menu.

The AIs i have installed is CluelessPlus 12, WrightAI 3
The AI libraries i have installed is:
Graph.AyStar.6
Pathfinder.Rail.1
Pathfinder.Road.3
Queue.BinaryHeap.1
Queue.FibonacciHeap.2
Queue.PriorityQueue.2

When I removed the Ai directory and recreated it, the problem disappeared, so obviously there was something there that was wrong.
Comment by Remko Bijker (Rubidium) - Monday, 16 November 2009, 23:42 GMT
Can't reproduce the crash (in current trunk) with that given set of libraries/AIs. Do you by any chance have the configuration file from before you removed the AI directory? Actually, do you have a copy of that AI directory too?

Loading...