OpenTTD

Tasklist

FS#3289 - Chrash when opening any vehicle list

Attached to Project: OpenTTD
Opened by Chris Huebsch (chu) - Saturday, 31 October 2009, 08:42 GMT
Last edited by Remko Bijker (Rubidium) - Saturday, 31 October 2009, 10:09 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Linux
Severity High
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This time a plain new svn-checkout, without any changes, without any additional grf-files and even without playing anything.

1) Started a new game
2) Click on "list of trains"
3) CRASH

BTW: This is the same bug, I reported recentlty. But it was rejected twice as probably beeing caused by a modified source... If you had asked, I could have told you, that my changes did not modify any data, but only repaired some glitches in the interface when plaing in German... but you did not ask. In my opinion a very inappropriate style. (Someone said: "it reminds me of microsoft"). Well...
This task depends upon

Closed by  Remko Bijker (Rubidium)
Saturday, 31 October 2009, 10:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r17912; not the same issue as  FS#3284  / FS#3286  though.
Comment by Zdeněk Sojka (SmatZ) - Saturday, 31 October 2009, 08:52 GMT
I can't reporoduce it in r17911.

There have been many cases of people reporting problems caused by modified binaries. Devs spent a lot of time with them that could be spent in a more useful way.
"repairs glitches in GUI" implies "crashes in GUI are not our problem, even worse when we can't reproduce it easily"
Comment by Remko Bijker (Rubidium) - Saturday, 31 October 2009, 09:38 GMT
1) Modified source is modified source, whether you modified the code that crashes or not.
2) Did you read the readme/website page about reporting bugs? Especially the parts about not reporting bugs in custom versions ( FS#3284 ) and not reporting duplicate bugs ( FS#3286  vs this one)?
3) If I make a Microsoft Word document in Microsoft Word, then open it in whatever editor, resave it and it fails to work right in Microsoft Word: is that a bug in Microsoft Word? Should Microsoft support whatever variations third parties make on their file format?
4) If I were to ask about the changes I had to ask about *all* changed versions of OpenTTD you used to (load and) save the supplied savegame with, just to determine whether you would have broken the savegame way before. Would you been able to comply? Do you still have the 42 (yes I have counted them twice) patches you applied from r14536-r17902? Do you think it is reasonable to check all those patches?
5) If I haven't seen the patch and don't really know the developer of the patch I don't really trust what they say about it. They claim the patch is "multiplayer safe" or "bug free", yet when I do only a source review I come up with several bugs/issues and regularly find things that make it multiplayer unsafe. Maybe it's not true in this case, but if it's true in the vast majority of cases, would it be wrong to assume that it's fishy until proven otherwise? (Or should we just add all and any patches assuming they're fine?)
Comment by Chris Huebsch (chu) - Saturday, 31 October 2009, 09:41 GMT
Edit: This was a response to SmatZ' comment.

If you read my post again, you will easily see, that this bug was filed for a non-modified trunk-version of ttd.
In other words: No changes at all.

"repairs glitches in GUI" means (and does not imply) increased window-sizes to see the texts fully. It does not imply, that there are changes in your ttd/src/core/pool_type.hpp. Of course, you are free to suggest something that way, but rest assured, that this will not improve my eagerness to submit bugs or patches anymore.

I write software since more than 20 years. And at work I spent most time, hunting bugs and dissecting broken software. So don't lecture me in that way.

And perhaps - instead of spending your time in explaining why you do not like to work on bugs - you could have asked what settings I am using.

Then I would have told you, that I do not use that "extended vechicle list" even for myself. Turning that off to default ("just for me"), ttd no longer crashes. But I did not read in your holy readme, that using simple vehicle lists is not allowed anymore.

I could have spend this 30 min for yet another complete checkout in a much more useful way too.
Comment by Remko Bijker (Rubidium) - Saturday, 31 October 2009, 09:41 GMT
Oh, with "list of trains" you mean "vehicle list", not "group list"? That makes it not a duplicate, so scrap the second point of my previous comment.

Loading...