OpenTTD

Tasklist

FS#3264 - Lots of cut messages in tooltips (Japanese Translation)

Attached to Project: OpenTTD
Opened by agro (agro1986) - Tuesday, 13 October 2009, 08:47 GMT
Last edited by Remko Bijker (Rubidium) - Tuesday, 13 October 2009, 20:19 GMT
Type Bug
Category Interface
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

using r17769 for Windows XP (using XP service pack 2)

I'm using the Japanese translation. Many of the tooltip messages are cut off, so I think there is a systematic cause to it.

Example: when clicking a factory, and then right clicking the window title of the window that pops up, it says:

"ウインドウのタイトル -
ウインドウを動かすには、クリックしてド"
(roughly: window title - to move the window, click and d)

And also, right clicking the pin button to the right of it, the tooltip will say:

"「すべてのウインドウを閉じる」をクリッ"
(roughly: If you click "close all windo)

Even right clicking the stuffs on the first ever main menu will reveal cut messages.

Relevant section of my cfg file:
small_font = MS PGothic
medium_font = MS PGothic
large_font = MS PGothic
small_size = 8
medium_size = 12
large_size = 18

Thanks a lot
This task depends upon

Closed by  Remko Bijker (Rubidium)
Tuesday, 13 October 2009, 20:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r17772
Comment by Remko Bijker (Rubidium) - Tuesday, 13 October 2009, 12:14 GMT
  • Field changed: Status (New → Confirmed)
Problem is that adding line breaks fails because it can't find spaces where to insert line breaks. If I understand correctly Japanese and some other languages don't require/need/allow spaces.
Comment by agro (agro1986) - Tuesday, 13 October 2009, 13:10 GMT
Yes, languages such as Japanese and Chinese don't use spaces. For those languages line breaks can be inserted virtually anywhere without making the result weird (e.g., when rendering, just insert a new line at the point where the text would exceed the maximum horizontal width).

Loading...